Cohesive documentation on deploying/customizing/locking down Firefox

RESOLVED WONTFIX

Status

Websites
wiki.mozilla.org
RESOLVED WONTFIX
14 years ago
4 years ago

People

(Reporter: mconnor, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

14 years ago
We need to create a cohesive set of docs on how to deploy/configure Firefox with
a minimum of effort.  There's some good information out there, and some nice web
tools, it'd be nice to have this all in one place.

some useful links dealing with this.

http://www.alain.knaff.lu/howto/MozillaCustomization/index.html
http://thegoldenear.org/toolbox/windows/docs/mozilla-pre-config.html
http://www.int-evry.fr/mci/user/procacci/netscape/en/mozilla-autoconfig-en.html
(Reporter)

Updated

14 years ago
Blocks: 241532

Comment 1

14 years ago
shouldn't this be moved to mozilla.org::webmaster@mozilla.org?
Component: General → Web Site
QA Contact: whiteclover79-bug
(Reporter)

Comment 2

14 years ago
*** Bug 250312 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 3

13 years ago
Rafael, I know you're working on this, let me know if you need any info etc,
this one is kinda near and dear to my heart, but I don't have the time right now.
Assignee: mconnor → rebron

Comment 4

13 years ago
*** Bug 283267 has been marked as a duplicate of this bug. ***
--> mozilla.org :: www.mozilla.org
QA Contact: danielwang → www-mozilla-org
Component: Product Site → www.mozilla.org
Product: Firefox → mozilla.org
Version: unspecified → other
http://developer.mozilla.org/en/docs/Deploying_Firefox

I'm working on trying to get some folks to fill in the blanks, folks who've actually deployed Firefox.  
Status: NEW → ASSIGNED
--> developer.mozilla.org
Component: www.mozilla.org → developer.mozilla.org
QA Contact: www-mozilla-org → qa
Component: developer.mozilla.org → Documentation Requests
Product: mozilla.org → Mozilla Developer Center
QA Contact: qa → doc-request
Version: other → unspecified
This isn't really appropriate MDC content.  Deployment documentation is currently being worked on at wiki.mozilla.org here:

http://wiki.mozilla.org/Deployment

When that content is more fleshed out, it will be moved to the most appropriate location.
Yeah, we should move it to another product, unless we want to just WONTFIX it.  I prefer the former, and will act boldly.
Component: Documentation Requests → Help Viewer
Product: Mozilla Developer Center → Documentation
Not really the right component, but the others were even less "consumer of this sofware" than Help Viewer is, so here we are.
Assignee: rebron → help.viewer
Status: ASSIGNED → NEW
QA Contact: doc-request → danielwang

Comment 11

9 years ago
Hmm, this is really the wrong component... How about sumo?
Assignee: help.viewer → nobody
Component: Help Viewer → Knowledge Base Articles
Product: Documentation → support.mozilla.com
QA Contact: danielwang → kb-articles
David, this may be out of our scope. What do you think?
This seems out of scope.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX

Comment 14

9 years ago
the wiki seems to be the place for this kind of documentation.  mkaply may have some thoughs on existing or new pages that are already out there.
Status: RESOLVED → REOPENED
Component: Knowledge Base Articles → Other
Product: support.mozilla.com → Websites
QA Contact: kb-articles → other
Resolution: WONTFIX → ---

Comment 15

6 years ago
IT departments are amongst Firefox users and corporates are becoming one of the Mozilla priority. See http://blog.mozilla.com/blog/2011/06/28/firefox-in-the-enterprise/

Nevertheless, the wiki page about the Firefox deployment is outdated.
Component: Other → wiki.mozilla.org
QA Contact: other → wiki-mozilla-org
As Chris H says, the wiki is probably the best place for this content, *however* the wiki is a repository of information created by everyone (ie not the wiki-team). As such this needs to be transferred (again) to a suitable group for content creation, or an invitation made to 'the public' to do so.

Given that this 'bug' was filed nine and a half years ago, the appropriate action now would seem to be to close it on a 'WONTFIX' basis but with an invitation to "SODOIT" to whomever _is_ responsible for documentation.
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.