Cut/Copy/Paste keyboard commands (Ctrl-X/C/V) from address/location/URL bar fails

VERIFIED FIXED

Status

()

Firefox
Toolbars and Customization
--
major
VERIFIED FIXED
14 years ago
8 years ago

People

(Reporter: David A. Cobb, Assigned: Pierre Chanial)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20031022 Firebird/0.7+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20031022 Firebird/0.7+

With the address in the AB highlighted, Ctl+c or Ctl+x would be expected to copy
the URI to the clipboard.  They do not, the previous content of the clipboard is
undesturbed.

Reproducible: Always

Steps to Reproduce:
1. Launch an app such as Notepad to provide a place to paste into;
2. Copy some recognizable text to the clipboard;
3. In Firebird, select the URI in the address bar [AB];
4. Either Ctl+c or Ctl+x;
5. Go to the Notepad app and paste (Ctl+v) the clipboard contents.

Actual Results:  
The original (step 2) contents of the clipboard are pasted.
Also, when using Ctl+x [cut] the string was not removed from the AB.

Expected Results:  
The URI copied from the AB in step 4 should be pasted. If Ctl-x was done, it
should have cleared the AB.

Comment 1

14 years ago
Tweaking summary, OS

Confirmed on Win2000, 20031022 build. It should be noted that you also cannot
paste into the URL bar using Ctrl-V. This is a regression from yesterday's build
as far as I can tell. Also, the bug is Firebird only, today's Mozilla nightly
works fine. There were some giant checkins over the last couple days, but my
suspicion is that bug 200884 broke things, its changes to autocomplete.xml deal
specifically with ignoring Ctrl -key combinations.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
OS: Windows XP → All
Summary: Cut/Copy from address bar fails → Cut/Copy/Paste from address (URL) bar fails

Comment 2

14 years ago
CC'ing Chanial...I apologize for the spam if you had nothing to do with this,
but the checkin of this code looked like a likely suspect to my untrained eye:

// this handler is called before the one in search.xml                
// that's sucks because the next line will also cancel                
// keys like ctrl-L, ctrl-N in the search bar.                        

if (aEvent.ctrlKey || aEvent.metaKey || aEvent.altKey)
  return false; // don't capture key + modifiers

Am I onto something?

Comment 3

14 years ago
Tweaking summary some more; -> toolbars; -> major.
Reassigning to Pierre (and toolbar QA).

Workaround: Right-Click in the location bar, select cut/copy/paste.
Assignee: blake → p_ch
Severity: normal → major
Component: General → Toolbars
QA Contact: bugzilla
Summary: Cut/Copy/Paste from address (URL) bar fails → Cut/Copy/Paste keyboard commands (Ctrl-X/C/V) from address/location/URL bar fails
(Assignee)

Comment 4

14 years ago
yup, I know I introduced this problem.
I will fix it soon.

Comment 5

14 years ago
I don't see this bug on my Linux build Mozilla/5.0 (X11; U; Linux i686; en-US;
rv:1.6a) Gecko/20031022 Firebird/0.7+ (persist,gtk2+xft)

Comment 6

14 years ago
Sorry for that last comment, I didn't follow the instructions properly. I can
reproduce this bug.

Updated

14 years ago
Flags: blocking0.8?

Comment 7

14 years ago
Using: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031018 Firebird/0.7 

I'm experiancing a similar problem, where ctrl+c and such work, but it should
put it in the middle-click buffer if I select the text in the address bar

Comment 8

14 years ago
I saw exactly what Jon saw (comment 2) in autocomplete.xml (around line
325-340ish).  And yes, it is control-key specific; shift-insert works to paste
in the address bar.

I'm going to overnight autobuild a build with a backout of the patching from bug
200884 if anyone's interested.  (Of course they are, I hear everyone
complaining.)  Backing out the changes to bug 200884 seemed like a good
temporary solution for custom builders.

http://forums.mozillazine.org/viewtopic.php?t=31209
(Assignee)

Comment 9

14 years ago
/me bets it will be fixed tonight
(Assignee)

Comment 10

14 years ago
fixed. I should have earn money, here. :)
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 11

14 years ago
Thanks Pierre, works again. -> verified.
http://bonsai.mozilla.org/cvsquery.cgi?date=explicit&mindate=10%2F23%2F2003+23%3A55&maxdate=10%2F23%2F2003+23%3A55
Status: RESOLVED → VERIFIED
Flags: blocking0.8?
*** Bug 223534 has been marked as a duplicate of this bug. ***

Updated

11 years ago
QA Contact: bugzilla → toolbars
You need to log in before you can comment on or make changes to this bug.