Autocomplete of email addresses in compose fails if a file dialog is open

RESOLVED WORKSFORME

Status

defect
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: coldchrist, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030827
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030827

If you have a file dialog open (e.g. for saving a web page, or downloading a
file) from either the browser or the mail window, then autocomplete does not
work in the compose window.

Reproducible: Always

Steps to Reproduce:
1. Bring up any web page, e.g. http://www.mozilla.org
2. Press Ctrl-S to bring up the save dialog.
3. Don't save the page; leave the dialog up and go to the mail window
4. Click on compose.
5. Type in the first part of an email address that ought to autocomplete.

Actual Results:  
The email address does not autocomplete in these circumstances.

Expected Results:  
Autocompletion should work regardless of whether there is a file dialog open.

Comment 1

16 years ago
Confirming; replicated with 1.5 Final and 1.6b-1120, Windows 2000.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → Windows 2000

Comment 2

15 years ago
Hmm ... Looks for me like a dupe of bug 74331. Could this be?
Product: MailNews → Core

Comment 3

15 years ago
See bug 150006 (autocomplete in URL bar) and bug 74331 comment 62.

Updated

13 years ago
Blocks: 327217

Comment 4

13 years ago
*** Bug 327217 has been marked as a duplicate of this bug. ***
sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody

Comment 6

11 years ago
TB2. Still happens in TB 2.0.0.14 (not 3)
-write
-go to another msg with attach, and say save (/browse ..)
-back to composing
**no autocomplete apparently 
close the browse /save attach ..
**autocomplete does in fact completed a contact, probably first proposed

It seams to just *not show* proposals, but actually does it silently ..

TB3. Same procedure works well in 3.0a (wfm 3 here ..)
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9pre) Gecko/2008050715 Lightning/0.6a1 Thunderbird/3.0a1 ID:2008050715

but this is TB and has no "browser" auto complete issue ..
Filter on "Nobody_NScomTLD_20080620"
QA Contact: esther → composition
(Assignee)

Updated

11 years ago
Product: Core → MailNews Core
cc: a couple SM folk in case they want to test

WFM in thunderbird 3
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME

Comment 9

10 years ago
Works for me.

Build identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.4pre) Gecko/20090929 Lightning/1.0pre SeaMonkey/2.0pre

Comment 10

10 years ago
WFM

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a1pre) Gecko/20090924 SeaMonkey/2.1a1pre
You need to log in before you can comment on or make changes to this bug.