Open Bug 223771 Opened 19 years ago Updated 10 years ago

Modifying bookmarks fails silently if bookmarks file is not writable

Categories

(SeaMonkey :: Bookmarks & History, defect)

defect
Not set
normal

Tracking

(Not tracked)

People

(Reporter: anton.pugl, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [2012 Fall Equinox])

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007

while online with Mozilla 1.4, Windows 2000 Professional suddenly restarted
(why?). Thereafter my bookmark.html file was empty. I copied an old version from
a backup copy. Now, Mozilla allows using and editing (Manage Bookmarks...) but
does not save the changes to the bookmark file! Update to Mozilla 1.5 did not
solve the  problem.

Reproducible: Always

Steps to Reproduce:
1.create a new profile
2.replace the bookmark.html file with an older Version from May 2003
3.rearrange the bookmarks in Manage Bookmarks...
4.exit Mozilla
5.restart Mozilla
Actual Results:  
6.the bookmarks are unchanged
7.the bookmark file date is unchanged also

Expected Results:  
stored the changes in the bookmark file, as it did if the bookmark file was not
replaced with an older version.

Deleting the profile and its directory, then copying the profile directory from
a backup das not work either. The profile directory is not recognized as a
profile by the Profile Manager.

Creating a new profile makes it work, but all my bookmarks and e-mails are not
acessible any more!
is the bookmarks.html file write-protected ?
Summary: bookmark.html is read only after copy from backup (was emptied after crash) → bookmark.html is read only after copy from backup (was emptied after crash)
unable to reproduce a bookmarks writing problem with 1.7 beta and bookmarks
files created in 1.4 and 1.6
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
Reopening

The easiest way to reproduce is to set the read-only attribute on bookmarks.html using attrib +R bookmarks.html from a command prompt. It can get in this state from restoring the bookmarks.html file using read-only media such as a CD backup. With WinXP the read-only attribute is removed when copying files from a CD but this does affect earlier versions of Windows - I believe Win2K and below.

Also see bug 322426
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Status: UNCONFIRMED → NEW
Ever confirmed: true
Reassigning as per Bug #32644
Assignee: p_ch → nobody
What is this bug about? IMHO this is invalid, the read-only attribute was user set  (ok, here unconsciously). Moz only respects this attribute, which is a correct behavior for the bookmarks file (could be wanted to have unchangeable bookmarks). I resolve this bug as INVALID. If you think this is incorrect, please feel free to reopen it.  
Status: NEW → RESOLVED
Closed: 19 years ago16 years ago
Resolution: --- → INVALID
a warning to the user that bookmarks are readonly wouldn't be such a bad user experience....
Most apps that respect the read-only attribute prompt the user whether they want to overwrite whereas we fail without any user notification. At most this bug might be wontfix by a module owner or peer... there have also been other bugs that have been fixed involving overwriting files that have a read-only attribute set. Also, if an admin wants to prevent a user from modifying bookmarks they should use file perms and not the read-only attribute since the user can unset the read-only attribute.

reopening
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Ok so changing summary to what this bug should be.
Status: REOPENED → NEW
QA Contact: bookmarks
Summary: bookmark.html is read only after copy from backup (was emptied after crash) → Warn/notify user if bookmark.html has read-only file attribute set
Summary: Warn/notify user if bookmark.html has read-only file attribute set → Warn/notify user if bookmarks.html has read-only file attribute set
Summary: Warn/notify user if bookmarks.html has read-only file attribute set → Modifying bookmarks fails silently if bookmarks.html has read-only file attribute set
Duplicate of bug 109377?
Despite move to Places, this bug still valid, for test purposes I revoke write permissions from places.sqlite file and tried to modify one bookmark and changes silently discarded.
User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 SeaMonkey/2.15a1
Build identifier: 20120921003032
OS: Windows 2000 → All
Hardware: x86 → All
Whiteboard: [2012 Fall Equinox]
Summary: Modifying bookmarks fails silently if bookmarks.html has read-only file attribute set → Modifying bookmarks fails silently if bookmarks file is not writable
You need to log in before you can comment on or make changes to this bug.