Flashplayer on www.sina.com.cn crashes browser on Linux

RESOLVED DUPLICATE of bug 202990

Status

()

Core
Plug-ins
--
critical
RESOLVED DUPLICATE of bug 202990
15 years ago
14 years ago

People

(Reporter: jerson.zeng, Assigned: Peter Lubczynski)

Tracking

({crash, stackwanted})

Trunk
x86
Linux
crash, stackwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)
Build Identifier: mozilla1.1

I got the mozilla soure code--mozilla-source-1.1.tar.gz from mozilla.org,
and compiled using --disable-debug and --enable-optimize on redhat linux8.0
simpled chinese.
then downloaded the flash player 6.0,installed it.
when I used the mozilla to browse www.sina.com.cn,crash erery time. 
i don't know why?

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
did you compile with gtk2?  What compiler version did you use?  FlashPlayer will
not work if you compiled with GCC 3.x...
(Reporter)

Comment 2

15 years ago
i compiled with gcc3.2 and gtk2.0,
but some webs havn't this proplem,
i find that if the web has some popup windows that play the flash, 
the browser will crash.
Since you're building yourself, please rebuild without --disable-debug and
attach a stack?
Keywords: stackwanted
(Reporter)

Comment 4

15 years ago
    thank you very much , i will have a try. 
(Reporter)

Comment 5

15 years ago
Stack

./mozilla-bin (pid = 28995) received Segmentation fault signal.
Stack:
nsProfileLock::FatalSignalHandler(int)+0x000000CC 
[/mozilla/dist/bin/components/libprofile.so +0x0002B514]
UNKNOWN 0x4032547e
UNKNOWN 0x42028c48
_XimFilterWaitEvent+0x0000004D [/usr/X11R6/lib/X11/locale/common/ximcp.so.2 
+0x0001A16D]
UNKNOWN 0x40d68e3e
XFilterEvent+0x000000B5 [/usr/X11R6/lib/libX11.so.6 +0x0004F845]
UNKNOWN 0x41d893b8
XtDispatchEvent+0x000000CF [/usr/X11R6/lib/libXt.so.6 +0x0001B4DF]
XtAppProcessEvent+0x000001DB [/usr/X11R6/lib/libXt.so.6 +0x0002764B]
UNKNOWN 0x40314b18
UNKNOWN 0x404f497e
UNKNOWN 0x404f4e59
g_main_run+0x00000044 [/usr/lib/libglib-1.2.so.0 +0x000130F4]
gtk_main+0x000000BF [/usr/lib/libgtk-1.2.so.0 +0x000A86DF]
nsAppShell::Run()+0x00000062 [/mozilla/dist/bin/components/libwidget_gtk.so 
+0x00031AC2]
nsAppShellService::Run()+0x0000002F 
[/mozilla/dist/bin/components/libnsappshell.so +0x00044493]
UNKNOWN 0x805d89e
main+0x000001FE [./mozilla-bin +0x000164FC]
__libc_start_main+0x000000A4 [./mozilla-bin +0x000158D4]
That looks like a crash in one of your system libraries (ximcp.so).
(Reporter)

Comment 7

15 years ago
   how can i fix the bug,
can u tell my something  about library--ximcp.so in detail. 

_I_ can't.... ccing blizzard in case he knows what that lib is all about.
(Reporter)

Comment 9

15 years ago
  
   Thank u !!!
(Reporter)

Comment 10

15 years ago
Hi blizzard:

bugzilla bug 223922

Flashplay cause crash  

i attach a stack,and Boris Zharsky told me that 
that look like a crash in one of my system libraries (ximcp.so), i don't know  
what's ximcp.so and how i can fix the bug.

Stack

./mozilla-bin (pid = 28995) received Segmentation fault signal.
Stack:
nsProfileLock::FatalSignalHandler(int)+0x000000CC 
[/mozilla/dist/bin/components/libprofile.so +0x0002B514]
UNKNOWN 0x4032547e
UNKNOWN 0x42028c48
_XimFilterWaitEvent+0x0000004D [/usr/X11R6/lib/X11/locale/common/ximcp.so.2 
+0x0001A16D]
UNKNOWN 0x40d68e3e
XFilterEvent+0x000000B5 [/usr/X11R6/lib/libX11.so.6 +0x0004F845]
UNKNOWN 0x41d893b8
XtDispatchEvent+0x000000CF [/usr/X11R6/lib/libXt.so.6 +0x0001B4DF]
XtAppProcessEvent+0x000001DB [/usr/X11R6/lib/libXt.so.6 +0x0002764B]
UNKNOWN 0x40314b18
UNKNOWN 0x404f497e
UNKNOWN 0x404f4e59
g_main_run+0x00000044 [/usr/lib/libglib-1.2.so.0 +0x000130F4]
gtk_main+0x000000BF [/usr/lib/libgtk-1.2.so.0 +0x000A86DF]
nsAppShell::Run()+0x00000062 [/mozilla/dist/bin/components/libwidget_gtk.so 
+0x00031AC2]
nsAppShellService::Run()+0x0000002F 
[/mozilla/dist/bin/components/libnsappshell.so +0x00044493]
UNKNOWN 0x805d89e
main+0x000001FE [./mozilla-bin +0x000164FC]
__libc_start_main+0x000000A4 [./mozilla-bin +0x000158D4]

Comment 11

14 years ago
does it still happen with Flash 7.0 ? Talkback ID if crashing ?
Blocks: 211213
Severity: normal → critical
Keywords: crash

Comment 12

14 years ago
Talkback-ID (2004-09-15 08:38:45.0) but on Win32:
http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=823428

Comment 13

14 years ago

*** This bug has been marked as a duplicate of 202990 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.