Blinking caret is not drawn when Input element positioned inside of a Body with Overflow:Hidden

RESOLVED FIXED

Status

()

Core
Layout: View Rendering
RESOLVED FIXED
15 years ago
15 years ago

People

(Reporter: Ivan Sagalaev, Assigned: roc)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6a) Gecko/20031026 Firebird/0.7+
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6a) Gecko/20031026 Firebird/0.7+

In the following testcase Input element positioned partly outside of the Body
with Overflow:Hidden. When Input is focused a part of blinking caret inside of
the Body is not visible and a part of the same caret outside of the Body is
visible. 

P.S. An Input is positioned this way only to show the weird behaviour.
Practically I have a CSS-driven layout of a chat and an input box located inside
of an absolutely positioned block doesn't show a caret.

P.P.S. This doesn't affect typing, by the way...

Reproducible: Always

Steps to Reproduce:
1. Load the following testcase
2. Click inside of an Input
3.

Actual Results:  
Part of caret *outside* of a Body is visible and blinking.

Expected Results:  
Part of caret *inside* of a Body should be visible and blinking.
(Reporter)

Comment 1

15 years ago
Created attachment 134427 [details]
a testcase
Happens on Linux too.
Assignee: other → roc
Status: UNCONFIRMED → NEW
Component: Layout → Layout: View Rendering
Ever confirmed: true
OS: Windows 98 → All
Hardware: PC → All

Comment 3

15 years ago

*** This bug has been marked as a duplicate of 216353 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

15 years ago
The testcase in this bug works for me in Mozilla/5.0 (Windows; U; Windows NT
5.0; en-US; rv:1.6b) Gecko/20031216 Firebird/0.7+. But bug 216353 is still
broken. May be this bug should be reresolved as a WFM, not a dupe of bug 216353?

Comment 5

15 years ago
I am very confident that this is a duplicate of bug 216353.
(and they both got fixed by the patch in bug 225811)

Ivan, please upgrade to the latest build and try again.

Comment 6

15 years ago
Ivan, you're right, this is not a dupe of bug 216353, sorry about that.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 7

15 years ago
This bug was fixed by the patch in bug 225811.

-> FIXED
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago15 years ago
Depends on: 225811
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.