bugzilla.mozilla.org will be intermittently unavailable on Saturday, March 24th, from 16:00 until 20:00 UTC.

Jpeg images duplicated and squeezed when printing on more than one page



MailNews Core
15 years ago
8 years ago


(Reporter: Peter Rothwein, Assigned: (not reading, please use seth@sspitzer.org instead))


Windows 95

Firefox Tracking Flags

(Not tracked)



(3 attachments)



15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.5b) Gecko/20030827
Build Identifier: Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.5b) Gecko/20030827

When printing an e-mail with jpeg attachments, images that cross between the
bottom of page 1 and the top of page 2 get squeezed... The result being two
distorted images.  This also happens with Win XP.  The last build that worked
properly was Moz 1.5b.

Reproducible: Always

Steps to Reproduce:
1. Open an e-mail with multiple jpeg attachments.
2. Print the e-mail (to paper)
3. Look at the resultant pages.

Actual Results:  
The image at the bottom of page 1 shrinks to fit the page regardless of how
little room is there.  Also, the top of page two duplicates the same picture
which also gets distorted because the height is smaller than it should be. 

Expected Results:  
Either break the image in half and print the first "half" on page one with the
second "half" on page 2 as was the case in 1.5b OR create page breaks so that
complete unbroken images would print.
Dup of a bug in the browser printing component...
Whiteboard: DUPEME

Comment 2

15 years ago
Sounds like bug 211648.

Comment 3

15 years ago
I have seen this misbehavior on Windows 2000 as well.  If I can make a test
case in 1.6a, I might confirm this bug.

Comment 4

15 years ago
This bug can be reprodued as follows, on Windows 98, Windows 2000 or Windows XP:
1. Go to http://vil.nai.com/vil/SystemHelpDocs/DisableSysRestore.htm
2. Print the page on an HP Laserjet 5L, 4Plus or 4200 PCL5e.
3. Notice that the second graphic is printed sqeezed on the first page, and
again on the second page.

This has happend with every version of Mozilla I have tried from 1.3 on.
Depending on where the image occurs in relation to the page boundary, both
copies may be squeezed to much to be useful.

Comment 5

15 years ago
Created attachment 135872 [details]
Tower used by test case

I have prepared a test case made of three attachments.	It consists of
a large HTML table with several tall images in rowspans, much like what
"cool" layouts circa 1998 did.

Comment 6

15 years ago
Created attachment 135873 [details]
Spacer image used by test case

Comment 7

15 years ago
Created attachment 135874 [details]
Test case for squeezing JPEG images

Test case: A six-column table, made of 120x120 pixel PNG spacers and
120x600 pixel JPEG tower images. The table is much taller than the page,
forcing the print engine to split some of the towers into two pieces.

Actual results: A whole tower image is squeezed into each piece of a tower.

Expected results: Each tower image prints at the correct proportion, and
the squares in the middle of the letters 'b' and 'g' are in fact square.

Comment 8

14 years ago

*** This bug has been marked as a duplicate of 211648 ***
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
Cleanup *dupeme* whiteboard flag from bugs that are marked as Resolved Duplicate!
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.