Closed Bug 224273 Opened 16 years ago Closed 16 years ago

Intranet URLs (such as http://james/) always redirect to http://www.randi.org/ when the intranet server is not responding.

Categories

(Firefox :: General, defect)

x86
Windows 2000
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 184433

People

(Reporter: ari.m, Assigned: bugzilla)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

Intranet URLs (such as http://james/) are treated as search strings in case the
server is not responding. This happens even if the URLs are perfectly legal and
complete. Because of this the example URL given above is redirected to
http://www.randi.org/ . There even isn't a configuration option available to
disable this automatic search. I think either evidently complete URLs should be
excluded from the search (and simple "server is not responding" message should
be shown) or it should be possible to turn this feature off.

Similar bug (ID 95390) is open for "Browser" as well, but in "Browser" you can
disable the "Internet Keywords" feature.

Reproducible: Always

Steps to Reproduce:
1. Pick an intranet host, that is not running a web server.
2. Try to open a page from the non-existing server using a complete URL, e.g.
http://james/
3. Notice the automatic search jump in and redirect you to a completely other
address

Actual Results:  
I am redirected to http://www.randi.org/

Expected Results:  
Shown me a message such as: Server not responding.
You can also disable it in Firebird.  Go to about:config and set keyword.enabled
to false.

*** This bug has been marked as a duplicate of 95390 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
REOPEN: Firebird is getting its own bugs.
Status: VERIFIED → UNCONFIRMED
QA Contact: benc
Resolution: DUPLICATE → ---

*** This bug has been marked as a duplicate of 184814 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago16 years ago
Resolution: --- → DUPLICATE
sipaq: this seems more like bug 184433, which has already been fixed.
reopening
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

*** This bug has been marked as a duplicate of 184433 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago16 years ago
Resolution: --- → DUPLICATE
V/dupe.

When there is no server running, you will now get an error.
Status: RESOLVED → VERIFIED
Some time within the past few weeks' updates (i.e. 33.1.1 or before), it seems, FF has now started searching by default if the URL is entered without http:// in front, even if the intranet server IS running and responding just fine.  This has become trouble for our users, who are used to being able to access local servers by typing their names in the address bar and hitting enter.  I hope this regression can be fixed.  It would be inconvenient to have to use manual config settings on every workstation just to restore this functionality.
You need to log in before you can comment on or make changes to this bug.