right and left border,margin and padding styles should be switched for RTL XUL element

RESOLVED WONTFIX

Status

()

Core
CSS Parsing and Computation
--
enhancement
RESOLVED WONTFIX
15 years ago
10 years ago

People

(Reporter: Mark Kaplun, Assigned: dbaron)

Tracking

({rtl})

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

Currently most (all ?) of the themes are desinged for the LTR user. The aim of
this RFE is to ease the use of those themes by RTL users.

The themes assume that the light source is at the upper left corner of the
screen, and therefor the shdow is on the lower and left side of menu elements.
For RTL GUI the light source is on the upper right side of the screen and the
shadow is on the lower and left side of the element. 

I'm somewhat on a more shaky ground with margin,border and padding size, but I
believe that it should also be switched. 

What is requested is that the switch will be made automaticly when an element
has an RTL direction.


Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Updated

15 years ago
Summary: right and left border,margin and padding styles should be switched for RTL XUL element → right and left border,margin and padding styles should be switched for RTL XUL element
Rather, we should implement the CSS3 proposals of
margin/border/padding-start/end and use those instead of left/right.  I don't
think the behavior of left/right is not exactly subject to change....
Assignee: mkaply → dbaron
Component: Layout: BiDi Hebrew & Arabic → Style System (CSS)
QA Contact: zach → ian
(Reporter)

Comment 2

15 years ago
Having start and end will be a really a nice solution. However I'm quite sure
that it will take some time before it is implemented, and even much more time
before theme writers are educated about it.

Can we have some kind of a hack right now, atleast for the menue border colors,
and fix the hack later? 

Comment 3

14 years ago
Where in CSS3 is this addressed? I can't find it in css3-box.
Note that margin/padding-start/end are already implemented (with the -moz prefix).

border-start/end could probably be done without too much pain if needed for themes.

In any case, implementing border-start/end would be a lot simpler than
implementing this RFE as filed.

Anne, this is not addressed in CSS3, because CSS3 introduces the *-start/end
properties.

Comment 5

14 years ago
I'm not sure I understand, it will introduce those properties globally or in a
separate specification?

Anyway, I guess this should be put in the "how to build a theme guide", if there
is one.
OS: Windows XP → All
Hardware: PC → All
(In reply to comment #5)
> I'm not sure I understand, it will introduce those properties globally or in a
> separate specification?

Looks like these properties are gone from the current CSS3 Box drafts.... they
used to be there, however.
The majority of the CSS working group consider that for Web authors, margin-
end/-start etc aren't very useful, since you'll need to do a lot more than just 
change the margins/padding/borders for rtl contexts. Those properties can be 
useful for UA stylesheets, which is why Mozilla has a vendor-specific extension 
for them.

Comment 8

14 years ago
Filed bug 260715 as follow-up. I'm going to mark this WONTFIX since we wan't
theme authors to use our vendor extensions.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX

Comment 9

10 years ago
Mass-assigning the new rtl keyword to RTL-related (see bug 349193).
Keywords: rtl
You need to log in before you can comment on or make changes to this bug.