tinderboxes need File::Spec perl module installed.

RESOLVED INVALID

Status

Webtools Graveyard
Tinderbox
RESOLVED INVALID
14 years ago
4 years ago

People

(Reporter: Benjamin Smedberg, Assigned: dbaron)

Tracking

Details

(Reporter)

Description

14 years ago
The XUL preprocessor is now part of the default seamonkey build, and requires
File::Spec 0.8

The btek tinderbox broke, and needs a perl upgrade.
I'm not the one to fix this.  Dbaron, can you do it?  If not, please pass the
hot potato.

/be
Assignee: brendan → dbaron
(Reporter)

Comment 3

14 years ago
That should be fine... dbaron, also see bug 224560 which is the same bug about
monkeypox.

Comment 4

14 years ago
I didn't file an extra bug for bewildered and nebiros, though.
(Assignee)

Comment 5

14 years ago
*** Bug 224560 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 6

14 years ago
Have you made appropriate updates to the Unix build documentation?
Summary: btek needs a perl upgrade → tinderboxes need File::Spec perl module installed.
(Assignee)

Comment 7

14 years ago
(The build documentation should say that on Red Hat 6.2 and other older Linux
distributions you need to install the File::Spec perl module.)
(Assignee)

Comment 8

14 years ago
I don't have access to the nebiros tinderbox.  caillon or jrgm might.

Comment 9

14 years ago
I looked at the build instructions, unix mentions 5.005, windows doesn't mention
a perl version at all. OS X doesn't mention perl at all. OS2 says 5.8
BeOS says 5.005, too.

My activestate Perl 5.6.1 has 0.82, cygwin 5.8.0 has 0.83. Not sure if we should
require 5.6 or 5.8. Opinions?
(I didn't manage to find package versions by perl release.)

The build instructions should either mention
Perl 5.8 or higher (or 5.005 with File::Spec version 0.8)
or
Perl 5.6 or higher (or 5.005 with File::Spec version 0.8)

Comment 10

14 years ago
I can access nebiros, but I don't have root access, so I can't install on nebiros. 
Looked for pav on irc, and now sent mail to find out who can do this.

Comment 11

14 years ago
Here is a snippet we could add to configure.in to test this.

I don't like the version check, it's not future compatible. But it should work
as a hack.

AC_MSG_CHECKING([for File::Spec 0.8])
_perl_filespec=`$PERL -e 'use File::Spec; if($File::Spec::VERSION =~ /0\.8/ ) {
exit(0); } else { exit(1); }' 2>&5`
_perl_res=$?
if test "$_perl_res" != 0; then
    AC_MSG_RESULT([no])
    AC_MSG_ERROR([Cannot find File::Spec 0.8.])
else
    AC_MSG_RESULT([yes])    
fi

Comment 12

14 years ago
Uh, wait a minute. nebiros is perl 5.6.1 and 
|perl -MFile::Spec -e 'print "$File::Spec::VERSION\n"'| says '0.82'

So is this really a File::Spec issue on nebiros?
(Reporter)

Comment 13

14 years ago
I have updated the detailed *nix build documentation at
http://www.mozilla.org/build/unix-details.html:

"Perl 5.6 or higher
Older perl versions may work if you upgrade File::Spec to version 0.8".

Comment 15

14 years ago
re #12,
there seems to be some confusion about which version of perl is used for the
nebiros build. From the build log, 


http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey-Ports/1067927580.15585.gz&fulltext=1

checking for perl5... (cached) /tools/ns/bin/perl5
checking for minimum required perl version >= 5.004... 5.00503
...
File::Spec version 0.8 required--this is only version 0.6 at
/builds/tinderbox/SeaMonkey/SunOS_5.7_Clobber/mozilla/config/preprocessor.pl
line 79.

Comment 16

14 years ago
I have no idea where nebiros is getting that idea...

nebiros / % which perl
/tools/ns/bin/perl

nebiros / % ls -l /usr/bin/perl
lrwxrwxrwx   1 root other 18 Oct 18  2001 /usr/bin/perl -> /tools/ns/bin/perl*

nebiros / % ls -l /bin/perl
lrwxrwxrwx   1 root other 18 Oct 18  2001 /bin/perl -> /tools/ns/bin/perl*

nebiros / % perl -v

This is perl, v5.6.1 built for sun4-solaris

Copyright 1987-2001, Larry Wall
<snip...>

nebiros / % perl -MFile::Spec -e 'print "$File::Spec::VERSION\n"'
0.82

nebiros / % perl -c
builds/tinderbox/SeaMonkey/SunOS_5.7_Clobber/mozilla/config/preprocessor.pl
/builds/tinderbox/SeaMonkey/SunOS_5.7_Clobber/mozilla/config/preprocessor.pl
syntax OK

nebiros / % perl
/builds/tinderbox/SeaMonkey/SunOS_5.7_Clobber/mozilla/config/preprocessor.pl
< /dev/null
nebiros / %

Comment 17

14 years ago
AC_PATH_PROGS(PERL, $PERL perl5 perl )
checks for perl5 before it checks for perl. And looking at the build log from
#15, it indeed finds
/tools/ns/bin/perl5
instead of
/tools/ns/bin/perl

Seems like the old perl5 installation is in the way. The client.mk on that 
machine could do
PERL=/tools/ns/bin/perl
to get around the perl5.
(Assignee)

Comment 18

14 years ago
For the record, this mess was caused by bug 204727.
(Assignee)

Comment 19

14 years ago
this should never have been filed nor fixed
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID

Updated

7 years ago
Component: Tinderbox Platforms → Tinderbox
Product: mozilla.org → Webtools
Product: Webtools → Webtools Graveyard
You need to log in before you can comment on or make changes to this bug.