If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

File names with periods not correctly MIME'd

VERIFIED DUPLICATE of bug 21789

Status

()

Core
Networking
P3
normal
VERIFIED DUPLICATE of bug 21789
18 years ago
18 years ago

People

(Reporter: umbrook0, Assigned: Gagan)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
This probably applies to all platforms, but I can't test it.

A file with periods in it, for example, a.b.html, is not correctly recognized as
an html file (at least using a file:// URI).

I suspect there is a DOS-ism in Mozilla which assumes everything after the first
period is the file extension, so it looks for ``b.html'' and can't find a MIME
type for it.

What you need to do is look for endings, so you check ``does it end with .html?
yes? then it is text/html'' -- in which case you have to check longer extensions
(such as .tar.gz) before shorter ones (.gz).

Updated

18 years ago
Assignee: nobody → gagan
Component: Browser-General → Networking
QA Contact: nobody → tever

Comment 1

18 years ago
Guessing that this falls under URL resolution...

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
*** This bug has been marked as a duplicate of 21789 ***

Comment 3

18 years ago
verified duplicate of 21789.  
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.