Closed Bug 2246 Opened 21 years ago Closed 20 years ago

[PP] Powerplant removal

Categories

(Core Graveyard :: Viewer App, defect, P2)

PowerPC
Mac System 8.5
defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 25949

People

(Reporter: mozeditor, Assigned: scc-obsolete)

Details

(Keywords: platform-parity)

We need to remove powerplant from seamonkey - at least from the non-app
libraries.  I (Joe Francis) will kick things off by rewriting the timer code to
not use LPeriodical.

Anyone reading this should feel free to add new description to this bug report
describing other places we need to "unplant".
Status: NEW → ASSIGNED
adding build people to the cc list...
adding build people to the cc list...
joe, what is the schedule for doing this?
added JJ Enser to list.

the change as i understand it is fairly trivial. we just stop building the
powerplant library.
The schedule is "soon".  Today or tomorrow.
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Powerplant is gone.  Affected parts of the tree are base, widget, netlib, and
viewer, and also the NGLayoutBuildList.pm script.

I have posted a note to n.p.m.mac about it, along with advice for those who were
using the pieces of PowerPlant that I just removed.
I'm not quite sure how QA can verify this. ;)

----

Simon/Steve/Mike/Chris/(et al ;), would one of you be open to marking this
verified, if you can definitively validate (or just vouch for? ;) that the MW
Powerplant stuff is totally out of Seamonkey?

Thanks!
Status: RESOLVED → VERIFIED
It's out. We no longer build it. Verified.
It depends on what one means by "totally out of".

There is a dependency on Powerplant header files (but not on the powerplant lib)
in viewer.  There may be header dependencies in other places - don't know for
sure.  But we don't need to build a powerplant library anymore - nothing links
against it.
Inserting Milestone info.
Status: VERIFIED → REOPENED
ftang wrote:

although we don't use powerplant anymore Caps.mcp don't build unless PowerPlant
source are installed (because xpassert.h include
PP_Type.h and UException.h). Can someone clean it up ?
Assignee: jfrancis → pierre
Status: REOPENED → NEW
Target Milestone: M2 → M4
Resolution: FIXED → ---
This also keeps us from building without exceptions.
adding scc to cc list
Assignee: pierre → scc
reassigned to scc
Actually, xpassert.h should not be included.  You should be using nsDebug.h
instead.  Nothing starting with xp should be in the build any more, including
xp_file and xpassert.
Status: NEW → ASSIGNED
Target Milestone: M4 → M5
targetting m5, cc ftang. where is xpassert.h being included in current code?  who
should get this bug?
I reassigned this bug to scc last month because it was somewhat related to the
removal of C++ exceptions and he's already on top of that.
Target Milestone: M5 → M7
moving to M7 as per discussion with choffman
Target Milestone: M7 → M10
This is not high enough priority to delay fixing my other bugs for.  I'm moving
this one out to M10 ... and the bulk of the work can't happen till the next
release of the CodeWarrior tools anyway.
Target Milestone: M10 → M11
Moving to M11 per today's bug triage.
Target Milestone: M11 → M16
No visible effect to users.  Not dogfood.
Keywords: pp
Removing the last of the PowerPlant header files is now part of the `conversion 
to Pro5' bug.  Therefor, marking this bug a duplicate.


*** This bug has been marked as a duplicate of 25949 ***
Status: ASSIGNED → RESOLVED
Closed: 21 years ago20 years ago
Resolution: --- → DUPLICATE
Verified dupe.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.