Firebird seems not to locate the Java engine

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: David A. Cobb, Assigned: Peter Lubczynski)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20031030 Firebird/0.7+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20031030 Firebird/0.7+

I have Java SDK 1.4 installed.  I re-install F-Bird not less than weekly.  When
re-installing I first blow away everything _except_ the plug-ins folder.

If I access a page with Java applets, I get the "puzzle-piece" icon and go into
a dialog about installing the plugin.  The cited mime type is X-(?)Application/Java.

Reproducible: Always

Steps to Reproduce:

Comment 1

15 years ago
Is it 1.4 or 1.4.2 ?

Comment 2

15 years ago
did you read thru this?
http://plugindoc.mozdev.org/phoenix.html
(Reporter)

Comment 3

15 years ago
One quick correction, then I'll go read the  plugin-doc.
The mimetype is "mimetype=application/x-java-vm"

Perhaps, if it is not applicable, MozFirebird should disable that jigsaw puzzle
leading to the Netscape Plugin Finder.

To WD, it is J2SDK 1.4.2

QUESTION: Is the environment variable "JAVA_HOME" relevant?

Comment 4

15 years ago
You need the appropriate registry keys, or use the unofficial installer.
http://plugindoc.mozdev.org/phoenix.html



*** This bug has been marked as a duplicate of 211226 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 5

15 years ago
All things considered, this page is more helpful:
<http://plugindoc.mozdev.org/faqs/phoenixwin.html>
(Reporter)

Comment 6

15 years ago
OK, I've installed all the registry patches.  What's more, I've re-installed
Java using Sun Java SDK 1.4.2 + netbeans.  Also set MOZ_PLUGIN_PATH to point at
various sources of plugins (java, quicktime, etc. ).  And about:plugins shows the 
Java Plug-in

    File name: NPOJI610.dll
    Java Plug-in 1.4.2 for Netscape Navigator (DLL Helper)

MIME Type 	Description 	Suffixes 	Enabled
application/x-java-vm 	Java Virtual Machine for Netscape 		Yes


Still doesn't work!  If I go to a page with applet I'm still where I was before.
Oh, I do not find any Java control panel aplet.
(Reporter)

Comment 7

14 years ago
Final discovery.
I had two (or maybe more) JVM's installed -- but not J2RE.  I had the J2EE and
the SDK, neither worked.  I installed the JRE per the pluginsdoc and I'm ok.

We need to put sometihing in the documentation about this (or get Sun to fix
things so any of the three installations work).  Therefore I'm reopening. 
As soon as notice has been taken of that, we can close it WFME.

Note, there is also an interaction problem with security software such as Norton
Personal Firewall that causes the first run of a Java-enabled page to fail
(notinited) until the firewall learns to permit the plugin to access the net. 

Anyway, it is NOT a dupe of http://bugzilla.mozilla.org/show_bug.cgi?id=211226
-- this bug does not apply to J2RE.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Updated

14 years ago
Summary: F-Bird seems not to locate the Java engine → Firebird seems not to locate the Java engine

Updated

14 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.