Not all forwarded e-mails show up as attachments

VERIFIED INVALID

Status

--
major
VERIFIED INVALID
16 years ago
11 years ago

People

(Reporter: jhouse, Assigned: sspitzer)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030925
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030925

I have not yet figured out the details, but I suspect that this bug is brought
about by my company switching to outlook.  Forwarded e-mails are showing up as
ForwardedMessage.eml and not getting inlined.

Reproducible: Didn't try

Steps to Reproduce:
1. Forward a message from Outlook
2. Open e-mail in mozilla
3.

Actual Results:  
e-mail has an attachment ForwardedMessage.eml which must be clicked on to view
the forwarded message

Expected Results:  
Displayed the forwarded message as inline

I escalated the severity simply because if there is a forward of a forward of a
forward of a forward of a forward...  it can become impractical to even try to
*read* the actual e-mail.  (there are other pitfalls there too...  when you open
the forwarded message it shows itself as an attachment meaning that a user
trying to get to the final e-mail might unwittingly make extra steps for themself)

There are a number of things that might be distinct bugs
* ForwardedMessage.eml shows up as the only attachment even if the forwarded
message contains other attachments (such as another forwarded e-mail)...
* When viewing a forwarded message, it shows itself as an attachment (in the
case with the ForwardedMessage.eml, it gets renamed to something more meaningful
but is still present along with the attachments to the forwarded message...
* In general it would be nice to be able to specify which attachments to inline
when possible...  Example items to inline or not: forwarded messages, pictures,
html files, .txt files, .cvs files, etc...   Note: size of an attachment might
be important.

Comment 1

15 years ago
Jason House: Check your setting of:    View|Display attachments inline

If unchecked, then this bug is a dupe of bug 227720; please mark it so.

If that setting is checked, please save the offending message to a .EML file and 
attach it to this bug.
(Reporter)

Comment 2

15 years ago
Well, I guess that is a brain dead mistake by me :)

I am closing this bug... but I think that there is probably plenty of room for
improvement in this general area...  For instance - I only want to see *some*
attachments inline...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Comment 3

15 years ago
v invalid

> ForwardedMessage.eml shows up as the only attachment even if the forwarded
> message contains other attachments (such as another forwarded e-mail)

If you find a message you can verify that with, open another bug (search 
Bugzilla to see if it's already reported, first...)

> When viewing a forwarded message, it shows itself as an attachment ...
> but is still present along with the attachments to the forwarded message...

That's bug 203570.

> In general it would be nice to be able to specify which attachments to
> inline when possible...  Example items to inline or not: forwarded messages,
> pictures, html files, .txt files, .cvs files, etc...   Note: size of an
> attachment might be important.

That sounds like a good idea for an enhancement request.  Showing attachment 
size is bug 26517.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.