common news / nntp error crashes / freezes thunderbird (too many connections from realm ...)

RESOLVED DUPLICATE of bug 224197

Status

--
critical
RESOLVED DUPLICATE of bug 224197
15 years ago
15 years ago

People

(Reporter: trash, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla Thunderbird 0.3 (20031013)

When I expand the News account, frequently my ISP's news server must be busy,
and I get an error message pop-up: "too many connections from realm [my isp]". 
Thunderbird then hangs and starts using 100% of the CPU. 

Reproducible: Always

Steps to Reproduce:
1. Configure a news account for an NNTP server that responds with "Too many
connections..." error.
2. Try to expand that account in the left-hand window that lists accounts and
folders.

Actual Results:  
(1) A dialog box popped up that has the heading "Alert", an "!" icon, and the
message "A News (NNTP) error occurred: too many connections from real xxxx
(xx.xx.xx.xx)".
(2) Thunderbird stops responding.
(3) CPU usage is 100%, pulled by Thunderbird.

Expected Results:  
Either (1) show the alert and allow you to clikc OK, then leave the News folder
collapsed, OR;
(2) with timeouts and retries, persevere.  This seems to be what Outlook Express
does, as I don't have this problem with Outlook Express, and my ISP's news
server seems to only be in this state for brief periods as connections come and go.

Comment 1

15 years ago
I have also experienced this issue, more information and screen shots here:

http://forums.mozillazine.org/viewtopic.php?t=32500

Error message:

Error. Too many connections from realm myISP.com

I get the same message in Outlook Express quite often but I just press ok and 
it stops for a while then tries again, this would be the expected behaviour.

*** This bug has been marked as a duplicate of 224197 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.