Closed Bug 225217 Opened 18 years ago Closed 14 years ago

Thai cannot be displayed.

Categories

(Core :: Layout: Text and Fonts, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: tom, Unassigned)

References

(Blocks 1 open bug, )

Details

(Keywords: intl)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: All current mozilla browsers

If the OS X 10.3 version of the Thonburi Thai font is installed, no Mozilla-type
browser will display Thai.  Instead, they display the MacRoman characters
corresponding to the TIS-620/MacThai hex representing the underlying Thai text,
even when this text is encoded as UTF-8.  No problem can be found with the font,
but somehow it seems to trigger a bug in Mozilla's Thai rendering.  You can also
contact Deborah Goldsmith at Apple (goldsmit@apple.com) for her reading of the
problem. 

Reproducible: Always

Steps to Reproduce:
1.Make sure OS  X 10.3 Thonburi font is installed.
2.Point Mozilla browser at site with Thai (e.g. www.columbia.edu/kermit/utf8.html)
3.Try to read Thai text

Actual Results:  
I got MacRoman gibberish.

Expected Results:  
Displayed proper Thai script.
Hmm. that's odd. Mozilla and Camino   on Mac OS X don't make use of ATSUI (well,
it uses it a little) so that I expect Thai text not to be properly shaped, but
hex string corresponding to MacThai/TIS620 encoding of the underlying text ?
Wow, that's ....
 
There's a bug filed for the CTL issue(bug 205476 and bug 121540). See also
http://www.mozilla.org/releases/mozilla1.5/known-issues-int.html

I wish I had a Mac so that I can fix this and other complex text rendering
issues on Mac OS X......

Anyway, Tom, could you attach a screenshot? 

re Thonburi font. Do you know what kind of font that is? Is it an AAT font with
mort table for Thai shaping? Do you know what CMap tables are included in the font? 
Status: UNCONFIRMED → NEW
Component: Layout: Fonts and Text → Layout: CTL
Ever confirmed: true
Keywords: intl
Attached image screenshot
relaying what Tom sent to me via email. guess he meant to post it here :-)
Comment on attachment 135186 [details]
screenshot 

And he also wrote that thonburi font doesn't have any CMap table (wtih PID=3).
As he wrote, that shouldn't matter.
Comment on attachment 135186 [details]
screenshot 

sorry for spamming.
Attachment #135186 - Attachment is patch: false
Attachment #135186 - Attachment mime type: text/plain → image/jpg
Tom, you don't have any problem using the font in other applications, do you?
(TextEdit and safari for instance. )  It looks like somehow Mozilla uses
MacRoman Cmap instead of MacThai Cmap. 
The problem only occurs with Mozilla or any browser using the same engine, and
not with any other app as far as I know.
Still a problem with Firefox 1.0. Safari renders correctly.

Is there a workaround?  Maybe a different font?
(In reply to comment #7)
 
> Is there a workaround?  Maybe a different font?

Well, the work-around is to set your Thai font preferences to use Lucida Grande
(or XXX.serif, XXX.sans-serif, XXX.monospace to match the XXX.fantasy and
XXX.cursive, in which case they will fallback to Lucida Grande anyway).

See my bug 159809 comment 25 and following for my unschooled speculation.

Blocks: thai
*** Bug 305394 has been marked as a duplicate of this bug. ***
This was FIXED on trunk by cairo and the checkin for bug 299222.  There are still a couple of bugs on 10.5 with certain Thai fonts; they're filed.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Component: Layout: CTL → Layout: Text
QA Contact: ian → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.