Bug 65896 (thai)

Thai support -- tracker bug

NEW
Unassigned

Status

()

defect
19 years ago
2 years ago

People

(Reporter: bstell, Unassigned)

Tracking

(Depends on 4 bugs, {intl, meta})

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
integrate the Thai support from Sun
(Reporter)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Future
(Reporter)

Updated

18 years ago
Depends on: 79287
(Reporter)

Updated

18 years ago
Depends on: 79284

Comment 1

18 years ago
I've added 84380 and 84394 as two bugs that are filed to track thai ctl
integration.
Depends on: 84380, 84394

Comment 2

18 years ago
reassign to shanjian
Assignee: bstell → shanjian
Status: ASSIGNED → NEW

Comment 3

18 years ago
accepting
Status: NEW → ASSIGNED
*** Bug 109527 has been marked as a duplicate of this bug. ***

Comment 5

17 years ago
prabhat:
Can we close this bug now or are there any issues left ?

Comment 6

17 years ago
hi roland - All the code to support thai on *nix is checked in. But before i
answer your question, I need to consult with arthit who is helping us with testing.
arthit, pl let update this bug if you have pending/outstanding issues (pl list
bugzilla ids) - thanks,

prabhat.

Comment 7

17 years ago
What about making this bug a "tracker bug" then, e.g. stamp it with the "meta"
keyword and make all open CTL-releated bugs depend on this one ?
Prabhat,
As of my test, most of the bugs related to Thai input/display has been fixed (thx :) )
I'll see if there's any more issue that still need a fix.

Here's a list of, not close yet, Thai related issues that i've found.

Bug #7969 - (All) Thai dictionary-based line/word breaker integration
Bug #74123 - (Mac) in CTL keyboard, Mozilla assert a lot
Bug #79287 - (All) Cell-based caret operations unsupported under Mozilla
Bug #117484 - (All) Incorrectly display, using "MS Sans Serif" font, Thai Character 
Tho Thahan (0E17)
Bug #119338 - (Win) text display as box in some Thai page


BTW,
Now CTL is not enabled by default.
Will it enabled by Mozilla 0.9.9 ?
additional CTL related issue:

Bug #122552 - (All) Caret cannot move all along the text, got stucked at some
position

----

Roland,
i agree with your idea, to make this a "tracker bug" :)

Maybe we need to change the summary/title text to better reflect its purpose ?


btw,
i had opened a bug #124574 "please add CTL in BugZilla's Browser-Component list".
(if CTL is a component, pls add it Bugzilla Component listbox ...for more easy
query & report)
Quite unrelated to the issue's title, but as it becomes a meta bug track, may I
update a small patch
for Thai shaper that has been checked-in to pango?

It's about glyph code point for shifted-left "MAITAIKHU".

PS. I'm not from Sun. :b
Bug #127661 - Mozilla render Thai vowel incorrectly in align=justify table

Thai non-base-level characters (e.g. upper/lower vowels) are mispositioned,
they are all shifted to the right, when has been putted in the table with align
= justify.
(see screenshots in that bug)

Seems the JUSTIFY doesn't support non-base-level characters,
so this bug should occurs with any script that has non-base-level chars also.

character width problem?
in which mozilla release will CTL enabled by default ?
this 1.0 RC1 ? 1.0 ?

Comment 13

17 years ago
Unfortunately the CTL extension is currently busted, that's bug 133212
("--enable-ctl bustage") ... ;-(
Thanks Roland.

comment #7 From Roland Mainz
> What about making this bug a "tracker bug" then, e.g. stamp it with the "meta"
> keyword and make all open CTL-releated bugs depend on this one ?

bcoz this is a "tracker" bug,
should we need to add that "--enable-ctl bustage" (bug 133212)
to the dependcy list ? (also the other bugs # e.g. 7969, 122552, 127661 ...)

i can't add them by myself.
Bug #127755 - ISO-8859-11 (Latin/Thai) Support

ISO-8859-11 is another Thai characters encoding standard.
current Mozilla release (0.9.9) doesn't support it yet.
Bug #143321 - [CTL-Thai] non-base level char can't be displayed alone (without
base char)
....Mozilla should be able to handle this.

Updated

17 years ago
No longer depends on: 143321

Updated

17 years ago
Depends on: 143321
Bug #144384 - (Solaris/Linux) [CTL-Thai] Thai Character Mai Chattawa (U+0E4B) is
displayed with wrong glyph (critical)

Comment 18

17 years ago
I am going to work on this problem this week.
Bug #146290 - (All) Thai BELOW-level char after U+0E0E / U+0E0F cause an
overlapping of chars

Comment 20

17 years ago
Add a couple of bugs to dependent list.
Depends on: 7969, ctl_bustage, 144384, 146290

Updated

17 years ago
Depends on: 146658
Bug 146658 - (Solaris) unable to load ./libmozpango-thaix.so
Bug 151545 - (Solaris) text style "bold" and "italic" didn't applied with Thai text
Depends on: thai-bold-italic

Updated

17 years ago
Depends on: 152790
Bug 156881 - (All) Underline should skip (Thai) character/part-of-character that
is below the base line
Bug 157534 - (All) Edit->Find in Page found substring in Thai display cell, but
it shouldn't be
excuse me, can we change the "OS" from "Linux" to "All" ?

since many bugs listed in this "tracker bug" are not Linux-specific,
some bugs occurs in (almost) every platform.
Bug 157541 - (Solaris) Thai below-level characters doesn't instantly displayed
in textfield
157546 - (All) Thai IM: <delete> key should delete WHOLE Thai "display cell"
Depends on: 157546
157546 - (All) Thai IM: <delete> key should delete WHOLE Thai "display cell"
Bug 157546 - (All) Thai IM: <delete> key should delete WHOLE Thai "display cell"
very sorry for multiple posted :(

Updated

17 years ago
Depends on: 100170

Updated

17 years ago
Depends on: 167983

Updated

17 years ago
Depends on: 100173
Bug 100170 (Solaris) Cluster based caret operations unsupported
Bug 100173 (Solaris) Thai language selection broken.
Bug 167983 (Solaris) text with Thai/non-Thai combination, highlighting is not
match with selection

Updated

17 years ago
Component: Internationalization → Complex Text Layout

Updated

16 years ago
Keywords: intl, meta
OS: Linux → All
Bug 203406 - Performace enhancement in CTL code
Bug 203052 - write a simple wrapper over tis620-2 converter to use with Xft
build for Thai shaping
Alias: thai
Depends on: 203406
Summary: Thai support from Sun → Thai support -- tracker bug

Updated

16 years ago
Depends on: 203052

Comment 33

16 years ago
Nominating as depending: 
Bug 178735: cursor movement in textarea broken again [if --enable-ctl]
Bug 168762 (Unix) unix.js please add font definitions for Thai locale
Bug 211340 (Linux) reproducible crash in _XimThaiCloseIM ()
Bug 213045 (Linux) Thai diacritical letters printed next to letter, not above
[Xprint]
Bug 225217 (MacOS X) Thai cannot be displayed

Bug 226420 (All) Thai Localizatoin/Translation -- tracker

Updated

14 years ago
Depends on: grapheme-breaker
Bug 229896 - (All) we need a generic grapheme cluster breaker/iterator

Comment 36

14 years ago
Outstanding bugs:-

bug 7969 - All : need dictionary based Thai line breaker and intergrate into
line/word breaker { ICU? }
bug 100170 {FIXED} - Solaris -enable-ctl (should be All) : Cluster based caret
operations unsupported
	{doesn't work on Windows. Do we need a new issue for Windows?}
bug 229896 - All : we need a generic grapheme cluster breaker/iterator
	{should be the solution for all cluster handling problem for all platforms, ICU?}
bug 157546 - All : IM: <delete> key should delete WHOLE Thai "display cell"
bug 100173 - Solaris -enable-ctl (should be all) : Thai language selection broken.
bug 127661 - All : non-base char is incorrecly positioned (out of display cell)
when align=justify
	{on Windows, shaping works except when justify}
bug 143321 {WORKSFORME} - All : non-base level char can't be displayed alone
(without base char) 
	{still doesn't work, need separate issue on displaying invalid combining
character sequence}
bug 146290 - All : Thai BELOW-level char after U+0E0E / U+0E0F displayed at
incorrect position --> overlapped char 
	{this is a shaping issue, works on Windows }
bug 157534 - All : Edit->Find in Page found substring in Thai display cell, but
it shouldn't be
	{cluster handling problem}

Platform specific bugs:-
bug 157541 - Solaris : CTL's (e.g. Thai) below-level characters don't instantly
displayed in textfield
bug 117484 - Windows 98 : Wrong display with Thai Character Tho Thahan (U+0E17)
	{only for combination of MS San Serif+Windows 98}
bug 167983 - Solaris : text with Thai/non-Thai combination, highlighting is not
match with selection
bug 168762 - Solaris : unix.js please add font definitions for Thai locale
	{How do we set default font for Windows?}
bug 225217 - MacOSX : Thai cannot be displayed. {using Thonburi Thai font}

New feature:-
bug 156881 - All : Underline should skip character/part-of-character that is
below the base line (text-decoration-mode)
bug 226420 - All : Thai Localizatoin/Translation -- tracker

Maybe fixed?:-
bug 119338 - Windows NT : text display as box in some thai page.
bug 122552 {WORKSFORME} - Solaris -enble-ctl (should include Linux) : Caret
cannot move all along the text, got stucked at some position
bug 188288 - Linux -enable-ctl : caret movement  erratic with CTL enabled

Fixed:
bug 127755 - All : ISO-8859-11 (Latin/Thai) Support
	However, ISO-8859-11 has not been registered at IANA yet

Updated

14 years ago
Depends on: 61883

Comment 37

14 years ago
Shaping related issues:-

bug 214715 - Linux : add a port to use pango for font rendering
bug 215219 - Linux : add a bridge to Pango from Xft rendering code for CTL
bug 218887 - Windows ME : Use Uniscribe APIs in GFX:Win and layout/editor
bug 121540 - Mac OSX : Use ATSUI for text rendering on Mac OS X

Updated

14 years ago
Priority: -- → P3

Comment 38

14 years ago
We won't turn on 'CTL' on any platform, I think. See bug 215219, bug 214715, bug
218887, bug 260663, bug 229896, bug 157967, and bug 121540 (some of these were
already listed in the previous comment)

Comment 39

14 years ago
Forget this one in outstanding bugs:-
Bug 100173 - Solaris -enable-ctl : Thai language selection broken.

Comment 40

14 years ago
New bugs:-
bug 283271 - WindowsXP : CTL cluster-based operations unsupported
bug 283283 - All : Invalid combining character sequences display incorrectly

Updated

14 years ago
Depends on: 283271, 283283

Comment 41

14 years ago
make bug 283271 a tracker bug with :-

bug 283415 new - Windows : Caret must be moved by grapheme cluster boundaries
bug 283416 new - Windows : Selection must be done by grapheme cluster boundaries
bug 157534 - All : Edit->Find in Page found substring in Thai display cell, but
it shouldn't be
bug 157546 - All : IM: <delete> key should delete WHOLE Thai "display cell"
Depends on: 283415, 283416

Comment 42

14 years ago
bug 284265 - All : Default Thai fonts should be set appropriately on each platform
Depends on: 284265

Comment 43

14 years ago
shanjian is no longer working on mozilla for 2 years and these bugs are still
here. Mark them won't fix. If you want to reopen it, find a good owner first. 
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX

Comment 44

14 years ago
Mass Re-assigning bugs that Frank Tang Closed on March 1st Spam is his fault

Mass Re-Open to follow
Assignee: shanjian → nobody

Comment 45

14 years ago
Mass Bug Re-Open of bugs Frank Tang Closed with no good reason. Spam is his
fault not my own
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 46

14 years ago
Reassigning Franks old bugs to Jungshik Shin for triage - Sorry for spam
Assignee: nobody → jshin1987
Status: REOPENED → NEW
bug 314575 : Can't open file name in Thai
bug 336969 : Linux, Windows : Line Breaking with Pango/Uniscribe
(In reply to comment #48)
> bug 336969 : Linux, Windows : Line Breaking with Pango/Uniscribe

It's actually bug 336959

Updated

13 years ago
Depends on: 314575, 336959
bug 353776 - Linux : need the surrounding text support for some language input

(also applies to Thai XIM)

Updated

12 years ago
Depends on: 353776
Isriya voiced interest in localizing Firefox into Thai in bug 299423.

What we'd like to see here is someone from the Thai community go through the dependency queue of this bug again, and find out which are actually still existing. The hope is that a good deal of those bugs are fixed by now on trunk, either a Minefield nightly or Firefox 3 B1.

That would help us to see if we'll actually be able to deliver a good Firefox 3 for Thai users.
Axel,

I investigate the dependency queue in this bug and the result is attached in the CSV file.

In summary,
- 16 total bugs remain
- 2 are fixed, due to new text layout engine. Verified by Thep. Bugs
aren't closed yet.
- 1 is tracker bug, nothing to do with it
- 5 of them are Solaris-only. I have no Solaris to try.
- 7 of them are related to text cell/clustering issue. I consider them
as enhancement.
- 1 bug can be easily fixed. It's #284265 "Default Thai fonts should
be set appropriately on each platform"

In order to solve this, we should:
1. Verify bug status on Solaris. Could Arthit help on this?
2. Make agreement on 7 text clustering bugs. If all agree that they
are enhancement and not the blockage of Thai usage. We can move on.
3. Fix #284265
poked in bug 284265. I'm not sure if I care about Solaris at all, so I'm happy to dismiss category 1.

Regarding the text clustering bugs, if you guys think they're just an enhancement, we're probably fine with that, too. CCing pav and roc, too.
The cluster bugs are probably fixable fairly easily. If any are high priority, nominate them for blocking status or better still, offer a patch for review :-)
For what Isriya summarized in comment #52,

- Bug 283283 (invalid sequence rendering) is fixed for Linux. But this seems to depend on platforms' renderers.

- Bug 283271 looks like a meta-bug for cluster support, with only bug 157534 (searching) left for Linux.

- Bug 157546 (DEL deletes cell) is being re-fixed.

- Bug 353776 (IM surrounding) would be the next interesting one, though not a showstopper.

In summary:

Not a bug?
- Bug 283283 (rendering of invalid sequences)

Needs some works:
- Bug 157534 (searching)
- Bug 283271 (cluster supports meta-bug)

Interesting:
- Bug 353776 (IM surrounding)

Not now:
- Bug 229896 (cluster iterator)
- Bug 156881 (underlining)
(change name)

Bug 157541 – not enough foot room in textfield/location bar to display lower-level (part of) characters 

This bug is not Solaris-specific. At least it occurs in Linux as well
(and may not be a renderer bug, but a ui bug)

Updated

11 years ago
Duplicate of this bug: 283271

Updated

11 years ago
Depends on: 421275

Updated

11 years ago
No longer depends on: 61883

Updated

11 years ago
Depends on: 425900

Updated

11 years ago
Depends on: 425915

Comment 58

11 years ago
FYI.

Firefox 3 release tracker for Thai is at #443373

Comment 59

11 years ago
(In reply to comment #58)
> FYI.
> 
> Firefox 3 release tracker for Thai is at #443373
> 

My bad bugzilla's syntax.

FYI.

Firefox 3 release tracker for Thai is at bug 443373

Updated

11 years ago
Component: Layout: CTL → Layout: Text
QA Contact: teruko → layout.fonts-and-text

Updated

11 years ago
Depends on: 450011

Updated

11 years ago
Depends on: 450858

Comment 60

11 years ago
blocked by bug 450858
Unassigning owner, is a meta-bug. Resetting priority.
Assignee: jshin1987 → nobody
Priority: P3 → --
Target Milestone: Future → ---
Depends on: 1351578
You need to log in before you can comment on or make changes to this bug.