If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

RFE: back button could display a tree, instead of a simple list.

RESOLVED DUPLICATE of bug 187410

Status

()

Core
Document Navigation
--
enhancement
RESOLVED DUPLICATE of bug 187410
14 years ago
9 years ago

People

(Reporter: Darrell Fuhriman, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007

Every browser I've seen treats the back button for a particular window/tab as a
simple list.  It seems to me that an obvious enchancement would be to integrate
it more tightly with the history, allowing a user to trace the history in a more
flexible fashion.  That description may not make much sense, so let me show an
example.

I begin a browsing session on say Google, my results will be on a page we'll
call ResultPage. From ResultPage, I can go to another site (X), and look at a
page on site X, then maybe another page linked from site X (X1).  I decide
that's kind of interesting, but not really what I'm after, so I go back to
ResultPage and select site A, page A1, then page A1a, back to page A1, then page
A1b.  Now, it would be really neat if when I clicked on back button, I could get
to *any* of those pages I viewed since ResultPage, using submenus.  for instance:

If I were on page A1b, my back button and submenus, represented by "->", would
look like this:

A1 -> A1a
A
ResultPage -> X -> X1
                   X2 -> X2a
Google

The element on the menu bar would always be a linear progression back from the
current page, but submenus could carry forward down other paths previously taken.

Now, if using my back button from page X2, I would get this:

X -> X1
ResultPage  -> A -> A1 -> A1a -> A1b
                    A2
Google

A similar thing could be done on front button allowing me to get forward
to page "in front of" the page I'm currently on.




Reproducible: Always

Steps to Reproduce:

Comment 1

14 years ago
dupe of bug 187410 or bug 21521
Depends on: 187410

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 187410 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

9 years ago
Component: History: Session → Document Navigation
QA Contact: docshell
You need to log in before you can comment on or make changes to this bug.