Persona is no longer an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 225288 - thunderbird does not recognize mission control preferences
: thunderbird does not recognize mission control preferences
Product: Thunderbird
Classification: Client Software
Component: Preferences (show other bugs)
: unspecified
: x86 Windows XP
: -- major with 5 votes (vote)
: Thunderbird1.1
Assigned To: Scott MacGregor
Depends on:
Blocks: 279178
  Show dependency treegraph
Reported: 2003-11-10 20:34 PST by Gokhan Topalhan
Modified: 2005-07-25 14:34 PDT (History)
9 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---

the fix (609 bytes, patch)
2005-04-22 16:01 PDT, Scott MacGregor
no flags Details | Diff | Splinter Review

Description Gokhan Topalhan 2003-11-10 20:34:06 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007

With Firebird or Mozilla, it is possible to use 
pref("general.config.filename", "ect.cfg");
pref("general.config.vendor", "ect");

preferences in all.js and make the client query a web server to download
preferences. Support for this feature does not exist in Thunderbird.  I am sure

Reproducible: Always

Steps to Reproduce:
1. Read
and set up a mission control server as described in
2. Launch thunderbird
3. Observe web server logs to see a hit
Actual Results:  
No hits to the mission control servers coming from thunderbird client

Expected Results:  
Thunderbird should contact the web server and download the configuration and
apply them (lock some settings etc.), like Mozilla or Firebird does. However, it
looks like it doesn't do that.

When I compile thunderbird on Linux with just export MOZ_THUNDERBIRD=1
mk_add_options MOZ_THUNDERBIRD=1 set in the .mozconfig it actually works but of
course it's not thunderbird anymore.
Comment 1 Scott MacGregor 2003-11-10 22:05:16 PST
I'm curious, are you deploying thunderbird in an enterprise space that relies on
MCD? We at the Mozilla Foundation would probably be interested in talking to you
if so. 
Comment 2 David :Bienvenu 2003-11-11 14:34:22 PST
this should work fine if you build the pref extension, e.g., in mozconfig.txt,
add the following line:

ac_add_options --enable-extensions=wallet,pref
Comment 3 David :Bienvenu 2003-11-11 14:39:30 PST
However, not knowing that anyone was using the MCD stuff, I've changed it so
that the returned js file is unobscured... 
Comment 4 Charles Dominguez 2004-07-27 15:43:01 PDT
I can confirm this bug is still present in Thunderbird 0.7.1/0.7.2, on Windows,
Linux and Solaris. This is with the official Windows Build (20040707), official
Linux build (20040626), and the contributed Sun Forte build (20040630).

OS Information:
Windows: Windows XP Professional, SP1
Linux: Red Hat Enterprise Linux 3, kernel 2.4.21-15.0.2.EL i686
Solaris: Solaris 5.9 4/04 release, sparc, Sun-Blade-100

> this should work fine if you build the pref extension

Compiling in the pref extension doesn't help. It does create the autoconfig
scripts in default/autoconfig/. However, preferences still aren't applied to
Thunderbird. Checking the web server's access logs shows that Thunderbird isn't
requesting the configuration file from the server.
Comment 5 David :Bienvenu 2004-09-22 17:12:06 PDT
thunderbird looks for tbird.cfg, and expects it to be unobscured...
Comment 6 David :Bienvenu 2004-09-22 17:19:41 PDT
duh, sorry, it uses, as you say, whatever the general.config.filename is set to.
That file needs to be plain text, unobscured, unless you you've set the obscure


to whatever byte offset you want to obsucre by (mozilla used to use 7 or 13,
can't remember which...)

you're probably not getting this far, but you can turn on PRLogging for MCD:

set NSPR_LOG_FILE=c:\log.txt 

Comment 7 Barry Shaw 2004-09-22 18:41:33 PDT
I don't know if this applies to the windows version or not, but I've found in
the 0.8 relase for thunderbird on linux that general.config.obscure_value is set
twice, with two contradictory values.  In greprefs/all.js its set to:

pref("general.config.obscure_value", 13); // for MCD .cfg files

and in defaults/pref/all-thunderbird.js its set to:

pref("general.config.obscure_value", 0); // for MCD .cfg files

with second instance overriding the first.

Comment 8 Daniel Morante 2004-11-05 20:28:22 PST
Problem Still Exists in Version 0.9
Comment 9 Laurent Bauvens 2005-03-29 06:30:05 PST
It seems it doesn't function more in TB 1.02. 

Permit me a remark : Centralized configuration management is a big request
before beginning any enterprise deployment.
Comment 10 Gregg Berkholtz 2005-04-04 09:58:38 PDT
I can confirm this still doesnt work on at least Win32 either.

On a side note - is there any project/group setup to track enterprise
Thunderbird needs. As this issue alone is a significant hinderence in regards to
deploying Thunderbird to my aprox 500 users. Our users are average
non-technicnal folks being migrated from GroupWise - and therefore should never
have to manually configure most of the client's settings.

We're currently configuring and forcing settings with a combination of grep,
sed, and batch files, and manually editing the the mail.jar file to hide certian
UI fields. Nasty hacks at best...
Comment 11 Scott MacGregor 2005-04-22 16:01:21 PDT
Created attachment 181580 [details] [diff] [review]
the fix
Comment 12 Scott MacGregor 2005-04-22 17:11:21 PDT
fixed for 1.1
Comment 13 Jehan Procaccia 2005-04-26 14:12:42 PDT

I confirm the NEED for autoconfig ( or Mission Control Server whatever you call
it ...).
In our school, we "autoconfig" our 2000 students settings for mozilla mail an
navigator. In next september we'll be using Fedora Core3 which replaces by
default mozilla with Firefox and Thunderbird. I expect to keep on using
autoconfig ... as I documented it on (as already mentioned in this bug-report)
Now I tried to use it with thunderbird 1.0.2, but with no success. Maybe
beacause it is due to work only with 1.1 released !? as mentioned just above !.
Anyway, is the use of autoconfig with thunderbird is documented somewhere apart
from this bug report where I just learnt that the config file should be called
"tbird.cfg" . but where should it be positioned ? :
/usr/lib/thunderbird-1.0.2 ?

although I  export NSPR_LOG_MODULES=MCD:5 ; export
NSPR_LOG_FILE=/tmp/thunder.txt , there is nothing written in my thunder.txt
debug file :-(

You also mention compiling thunderbird with -enable-extensions=wallet,pref, but
how do you check that a package distribution of thunderbird (FC3 RPM) is compile
with that option !? in firefox you go to the URL "about:buildconfig" but here ??

Finally, I should mention that firefox 1.0.3 seems to allow autoconfig to work ,
but I still have lot of problems ... especialy with ldap queries 
the getLDAPAttributes functions fails  :-(
error popup messages is:
"Error: getLDAPAttributes failed: TypeError:
Components.classes[LDAPURLContractID] has no properties" 
Any clues on that (I did removed the --disable-ldap in compile options !) 
Autoconfig for firefox is VERY well documented on
but it doesn't uses ldap functions ... but maybe I'am out of subject here , I
should propably open a bug report on firefox, but if you have an idea before ...
that would help .

Comment 14 Christophe Pépin 2005-05-13 08:10:49 PDT
We NEED autoconfig too for thunderbird, for about 15000 users in a large
centralized deployment (we have one for netscape communicator 4.7 since 1998).
Waiting for 1.1.
Comment 15 Frank Wein [:mcsmurf] 2005-06-05 06:40:07 PDT
(In reply to comment #14)
> Hello,
> We NEED autoconfig too for thunderbird, for about 15000 users in a large
> centralized deployment (we have one for netscape communicator 4.7 since 1998).
> Waiting for 1.1.
> Thanks.

If there is a urgent need for autoconfig, you can always compile Thunderbird
yourself with
ac_add_options --enable-extensions=default,pref (that also works with 1.0.x)
Comment 16 Jehan Procaccia 2005-06-06 07:23:28 PDT
Indeed that works with the -enable-extensions compile time options !
I've just documented it on:
I don't know why it was marked as "fixed for 1.1" as it works even on 1.0.2 !?

however you need to recompile , it's easy (for me !) on linux, but not that much
on windows ..., see my problems on  ->
thunderbird Build -> windows Thunderbird build

hope these discussions will enhence to use and need of autoconfig .
Comment 17 Gregg Berkholtz 2005-06-27 16:29:36 PDT
It appears getLDAPAttributes() Win32 still fails on Win32. The popup error
message is:
 Netscape.cfg/AutoConfig failed. Please contact your System Administator
 Error: getLDAPAttibutes failed: [Exception... "Component returned failure code:
0x80570018 (NS_ERROR_XPC_BAD_IID)[nsIJSCID.createInstance]" nsresult:
"0x80570018 (NS_ERROR_XPC_BAD_IID)" Location: "JS frame :: file:///c:\Program
Files\Mozilla Thunderbird\defaults\autoconfig\prefcalls.js :: getLDAPAttributes
:: line 176" data:no]

This is on TBird version 1.0+ (20050626) - which from what I understand should
already have both autoconfig and ldap support compiled in. Correct?

My testing/static getLDAPAttributes() call:

The DN which contains the valid UID is actually under
ou=PDX,ou=People,dc=domain,dc=com, though I assume the lookup will search
subcontainers without issue.
Comment 18 Gregg Berkholtz 2005-07-20 09:45:24 PDT
It appears I was in error. As Thunderbird is apparently still not compiled with
the necessary mission control LDAP code enabled. Is there any chance such
support will be added to 1.1?
Comment 19 Jehan Procaccia 2005-07-22 01:44:47 PDT
I also confirm that latest nightly build doesn't support ldap
TB 1.0+ (20050721) -> yesterday build .
I also get the error while calling getLdapAttributes() from prefcall.js, error :

Netscape.cfg/AutoConfig failed. Please contact your System Administator
 Error: getLDAPAttibutes failed: [Exception... "Component returned failure code:
0x80570018 (NS_ERROR_XPC_BAD_IID)[nsIJSCID.createInstance]" nsresult:
"0x80570018 (NS_ERROR_XPC_BAD_IID)" Location: "JS frame :: file:///c:\Program
Files\Mozilla Thunderbird\defaults\autoconfig\prefcalls.js :: getLDAPAttributes
:: line 176" data:no]

however, other autoconf settings do work , but we cannot set pref from ldap
values which is very anoying for autoconfiguring email preferences ... :-( 

I also tested the latest stable TB 1.0.6 (20050716), I was positively surprised
to see the presence of the autoconfig sub-directory, which mean that is is now
ship with --enable-extensions=pref , good !, unfortunatly, I don't know why but
TB 1.0.6 complety ingore autoconfig, although I did put in pref/all.js :
pref("general.config.obscure_value", 0); // for MCD .cfg files
pref('general.config.filename', 'thunderbird.cfg'); // for MCD .cfg files
and put thunderbird.cfg in the root directory of TB, nothing is read :-( .

I'am afraid to be forced to use again mozilla (probably 1.7.10 for which
everything works fine) instead of firefox/thinderbird for our next september
academic year .
Thanks to let me know if there's a possible solution before .
Comment 20 Gregg Berkholtz 2005-07-25 11:59:36 PDT
Can this bug be re-opened, as this issue still appears unresolved. Or should a
new bug report be filed for just enabling the LDAP support noted in the last two
Comment 21 David :Bienvenu 2005-07-25 12:02:37 PDT
the latter, please, thx!
Comment 22 Gregg Berkholtz 2005-07-25 14:10:34 PDT
Does anyone know what The Thunderbird compile-time switch is for enabling LDAP
AutoConfig? Is it the same as FireFox's (--disable-ldap)?
Comment 23 Gregg Berkholtz 2005-07-25 14:34:18 PDT
If anyone wishes to vote for LDAP AutoConfig support in TB1.1. I've opened Bug

Note You need to log in before you can comment on or make changes to this bug.