Last Comment Bug 225474 - xml.cgi script has syntax problems
: xml.cgi script has syntax problems
Status: RESOLVED FIXED
[fixed in 2.16.5] [does not affect tr...
: regression
Product: Bugzilla
Classification: Server Software
Component: Bug Import/Export & Moving (show other bugs)
: 2.16.4
: All All
P1 critical (vote)
: Bugzilla 2.16
Assigned To: Dave Miller [:justdave] (justdave@bugzilla.org)
: default-qa
:
Mentors:
: 226979 (view as bug list)
Depends on: 217422
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-12 10:36 PST by Julio
Modified: 2012-12-18 20:46 PST (History)
4 users (show)
justdave: approval+
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Patch (1.37 KB, patch)
2003-11-12 14:04 PST, Dave Miller [:justdave] (justdave@bugzilla.org)
bbaetz: review+
Details | Diff | Splinter Review

Description User image Julio 2003-11-12 10:36:55 PST
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461; .NET CLR 1.0.3705; .NET CLR 1.1.4322)
Build Identifier: 

when invoking the xml.cgi script in version 2.16.4 perl rejects it both due to 
a syntax problem in the query, and 2nd because of a misnamed column.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.




The following line is the patch required to fix it in the file Bug.pm:

line 115 should be changed to:

groupset, delta_ts, ifnull(sum(votes.count),0)

No comma at the end, and the name of the count column is different.
Comment 1 User image Dave Miller [:justdave] (justdave@bugzilla.org) 2003-11-12 13:44:41 PST
F#$@$!!!!!

regression from bug 217422.

Looking at the patch that got checked in (which I wrote) that looks so damn
obvious, I could shoot myself for that.

My first thought was "why the hell is show_bug still working then?" because that
error should have killed show_bug as well.

Then it dawned on me that show_bug on the 2.16 branch wasn't using Bug.pm yet. 
Which means the original patch didn't fix what it was intended to fix anyway. (A
MySQL 4 compatibility issue on the show_bug screen).

New patch coming up.
Comment 2 User image Dave Miller [:justdave] (justdave@bugzilla.org) 2003-11-12 13:50:27 PST
For the record, my test box for Bugzilla 2.16 only has MySQL 3.23.54 on it, so
the symptoms of the MySQL 4 problem (votes showing up blank) weren't there.  I
applied the patch, tried show_bug (completely forgetting that it didn't use
Bug.pm) to make sure it still worked, and it did.
Comment 3 User image Dave Miller [:justdave] (justdave@bugzilla.org) 2003-11-12 14:04:49 PST
Created attachment 135346 [details] [diff] [review]
Patch
Comment 4 User image Bradley Baetz (:bbaetz) 2003-11-12 19:58:13 PST
Comment on attachment 135346 [details] [diff] [review]
Patch

Joy. r=bbaetz
Comment 5 User image Dave Miller [:justdave] (justdave@bugzilla.org) 2003-11-12 20:10:08 PST
Julio: care to give this a shot and make sure it still works for you?  Since
most of us on the dev team aren't using 2.16.x on a regular basis these days
it's hard for us to test things thoroughly on it anymore :(
Comment 6 User image Dave Miller [:justdave] (justdave@bugzilla.org) 2003-11-14 23:40:42 PST
Well, it works on my test install...

Checking in Bug.pm;
/cvsroot/mozilla/webtools/bugzilla/Bug.pm,v  <--  Bug.pm
new revision: 1.12.2.2; previous revision: 1.12.2.1
done
Checking in bug_form.pl;
/cvsroot/mozilla/webtools/bugzilla/Attic/bug_form.pl,v  <--  bug_form.pl
new revision: 1.93.2.4; previous revision: 1.93.2.3
done
Comment 7 User image Ulrich Windl 2003-12-02 05:27:43 PST
Hi, I thought I had reported the same bug as well, but couldn't find it again 8-(
However I've just tested your patch for 2.16.4 and mySQL 4.0.15: I'm still getting
SQL errors:
LEFT JOIN cc select at globals.pl line 271 (#1)
from bugs left join votes using(bug_id)
...
2.16.3 worked for the same version of mysql however. My OS is SuSE Linux 9.0, so
I guess some more people will have the same problems.
Comment 8 User image Dave Miller [:justdave] (justdave@bugzilla.org) 2003-12-13 21:59:29 PST
*** Bug 226979 has been marked as a duplicate of this bug. ***
Comment 9 User image Dave Miller [:justdave] (justdave@bugzilla.org) 2003-12-13 22:02:21 PST
Ulrich: what's the entire error message?  that looks abbreviated, and there's
not enough of it there for me to tell what you're hitting....
Comment 10 User image Ulrich Windl 2003-12-14 23:32:21 PST
I did not read the patch careful enough (I had applied it manually from one
screen to another): After removing the trailing comma in Bug.pm at line 115,
xml.cgi works again now. As you had already said, the bug was not obvious at
all. I guess now that the MySQL error is gone as well, you do no longer care to
see the full error messages from Apache's logs, do you?
Comment 11 User image Dave Miller [:justdave] (justdave@bugzilla.org) 2003-12-14 23:35:04 PST
correct.  glad you got it working :)

Note You need to log in before you can comment on or make changes to this bug.