"Has Attachments" filter does not work, Filtering multiple Received header, too

RESOLVED DUPLICATE of bug 105169

Status

SeaMonkey
MailNews: Message Display
RESOLVED DUPLICATE of bug 105169
15 years ago
14 years ago

People

(Reporter: Gerhard Wiesinger, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.00 (CP/M; 8-bit)
Build Identifier: 1.5, Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007

"Has Attachments" does not work for me:
"Attachment Status" is "Has Attachments"

After selecting that, no mail appears.
(With "isn't" all mails appear)

Mails are on an UW IMAP Server.

Also having a rule for the Received Header (there are normally more than one!!!) 
does not work.
(e.g. Received contains pop.myprovider.com)

It looks like that all headers which are not standard header do not work at all.

Any ideas?

Ciao,
Gerhard

Reproducible: Always

Steps to Reproduce:

Comment 1

15 years ago
"Attachment Status" is part of the the MailView (dropdown at top of thread pane) 
but not part of Filters.  Messages which have not yet been downloaded (such as 
the contents of an IMAP folder or newsgroup) have unknown attachment status, and 
so will not be shown when that mailview is selected.

It is true that Received headers are not available to either MailViews or 
Filters.
Component: Filters → Mail Window Front End

Comment 2

14 years ago
So this bug is INVALID? (In reply to comment #1)

Comment 3

14 years ago
RFE "filter for attachments": bug 105169

Comment 4

14 years ago
See also bug 182720, which is about the lack of an attachment icon after the 
message has been entirely downloaded (but not yet viewed).

I'm not sure if this bug is a dupe of that, of bug 105169, or neither.
Gerhard Wiesinger, what do you think?


Incidentally, I recently learned that my statement in comment 1 about received 
headers is incorrect; it is possible to filter/MailView on them.  (This may be 
new.)

Comment 5

14 years ago
No response from reporter. Please only one issue in a bug report. Resolving as
dupe for "filter for attachments". 

*** This bug has been marked as a duplicate of 105169 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.