form text remember any non Latin1 char as '.'

VERIFIED DUPLICATE of bug 29154

Status

()

Core
Layout: Form Controls
P3
normal
VERIFIED DUPLICATE of bug 29154
18 years ago
18 years ago

People

(Reporter: Frank Tang, Assigned: Frank Tang)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fix available - see 29154. reviewed. Wait for a= from rickg, URL)

(Assignee)

Description

18 years ago
pollmann- is this your area ?
1. Go to any URL which accept form text input, such as
http://home.netscsape.com/ja
2. type some Latin 1 and non-latin1 text and submit
3. Click "back"
4. The Latin 1 text in the form text field will be remember, but the non latin1
part will be remember as '.' instead.

Comment 1

18 years ago
Note that depending on which search engine page you use,
you might see only the blank field (i.e. nothing) when the
Back button is pressed. Yahoo Japan and Netscape Japan pages are
are like this:
http://www.yahoo.co/jp/

but Lycos Japan page returns dots for Japanese characters.

http://www.lycos.co.jp/

In any case, we should be seeing the original input in all of these
cases instead of dots or blanks.

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M13

Comment 2

18 years ago
Yes, this is probably a bug in the frame state storing or retrieval code.  I'll
take a look, thanks!

Comment 3

18 years ago
Correction on URL. Yahoo Japan Page is:

http://www.yahoo.co.jp/

Updated

18 years ago
Target Milestone: M13 → M14

Comment 4

18 years ago
Moving to M14, guessing I won't be able to get this in tomorrow.

Comment 5

18 years ago
** Update with 1/27/00 Win32 M14 build **

Now I see simply a blank form field with all the above
search URLs when I press the Back button. And it does not have
to be a non-ASCII input. ASCII input also has the same problem.

Comment 6

18 years ago
The form inputs not being remembered at all is bug 13537.  I'm marking as a
dependency as we need that fixed before we can work on this.
Depends on: 13537

Comment 7

18 years ago
Moving non PDT+ bugs out.
Target Milestone: M14 → M15
(Assignee)

Comment 8

18 years ago
I think part of the cause is bug 29154. Mark 29154 as blocking this.
Blocks: 29154
(Assignee)

Updated

18 years ago
Blocks: 28019
(Assignee)

Updated

18 years ago
No longer blocks: 28019

Comment 9

18 years ago
Bug 13537 was fixed on 2/11.
We should retest and update this bug report.
cc'd roberts to get opinion on need for Beta1.

If users are shopping or requesting info and clicking through 1 or more
forms, often they need to go back and enter missing or erroneous data.  How
important is this for Beta1? 
(Assignee)

Comment 10

18 years ago
This is important to report non ASCII related bug by using SeaMonkey with 
Bugzilla. If intl users using SeaMonkey to report bug on Buzilla and put down 
some non ASCII text, and he jump to other page to collect some data, when he 
return, the non-ASCII part will trun into ... . 
Put beta1 keyword into this. 
Keywords: beta1
(Assignee)

Updated

18 years ago
Depends on: 29521
(Assignee)

Updated

18 years ago
No longer blocks: 29154
(Assignee)

Updated

18 years ago
Depends on: 29154

Comment 11

18 years ago
Marking PDT- for beta1.  It's getting too late to go for these.
Whiteboard: [PDT-]

Comment 12

18 years ago
This might be a dup of bug 29521.
(Assignee)

Comment 13

18 years ago
this is not a DUP of 29521. IT is DEPNEND on 29521. You need to fix 29154 first 
before this get fix.
(Assignee)

Comment 14

18 years ago
remove [PDT-]. sfraser already fix 29521. Please consider this PDT+ again. We 
need to fix 29154 first to fix this since that bug is ONE of the reason which 
trash the data. 
Whiteboard: [PDT-]
(Assignee)

Updated

18 years ago
Assignee: pollmann → ftang
Status: ASSIGNED → NEW
Whiteboard: fix available - see 29154.
(Assignee)

Comment 15

18 years ago
It turn out it is a DUP of 29154 AFTER 29521 fixed. I have a fix now. See 29154 
for the patch. Reassign this to ftang. pollmann, please review the code. Thanks.

Comment 16

18 years ago
Reviewed - looks good to me!
(Assignee)

Comment 17

18 years ago
ready to check in . need rickg's approval
Status: NEW → ASSIGNED
Whiteboard: fix available - see 29154. → fix available - see 29154. reviewed. Wait for a= from rickg

Comment 18

18 years ago
per PDT, if rickg approves, go ahead and check in.
(Assignee)

Comment 19

18 years ago

*** This bug has been marked as a duplicate of 29154 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 20

18 years ago
VERIFY duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.