Minimum width too small when 'white-space: nowrap' used on inlines

RESOLVED WORKSFORME

Status

()

Core
Layout: Block and Inline
RESOLVED WORKSFORME
14 years ago
10 years ago

People

(Reporter: Wolf-Dietrich Moeller, Unassigned)

Tracking

({testcase})

Trunk
mozilla1.9
x86
Windows XP
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

Minimum cell width in table is not computed correctly when cell contains <span
style="white-space: nowrap">. This should either be ignored (as of CSS 2.0,
white-space allowed on block elements only) or it should be rendered (as of CSS
2.1, allowed on all elements). This behaviour is in-between.

The following refers to the attached test case:
To see the error the window must be smaller than the maximum table width, i.e.
the browser must start squeezing the tables.

In the upper and middle table the first name extends over the next columns also,
due to <span style="white-space: nowrap">. The minimum computed cell width is
only the length of the span region and does not include the rest of the word as
would be necessary.
For comparison the lower table has the same content as the upper table, only
style="white-space: nowrap" is changed to style="font-style: italic". Now the
rendering is okay. This is tested just to make sure the white-space property
really caused the error.

Tested with Mozilla (Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.4)
Gecko/20030624) and Firebird (Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7). Same on WindowsXP.

Reproducible: Always

Steps to Reproduce:
1. load the test case
2.
3.
(Reporter)

Comment 1

14 years ago
Created attachment 135703 [details]
testcase for showing bug

Comment 2

14 years ago
Bug 191699 is about supporting 'white-space' on inlines. It's possible that the 
implementation is only partially complete, see that bug for more details.
.
Assignee: table → block-and-inline
Component: Layout: Tables → Layout: Block & Inline
Depends on: 191699
QA Contact: ian
Summary: Minimum cell width in table is not computed correctly when cell contains <span style="white-space: nowrap"> → Minimum width too small when 'white-space: nowrap' used on inlines
Seeing this on Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6b) Gecko/20031208
Keywords: testcase

Comment 5

11 years ago
I can reproduce bug with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.1) Gecko/20061225 BonEcho/2.0.0.1

Comment 6

10 years ago
I have been responsible for investigating this bug and creating a workaround for it over at the English Wikipedia. This is the same bug as [[Bug 278891]] and probably very closely related to [[Bug 101565]] and many of the other bugs that turn up when I search for "nowrap" here.

Since it might be of help, here is our how-to guide about it at Wikipedia and a link to more info about it at the talk page: 
* http://en.wikipedia.org/wiki/Wikipedia:Line_break_handling#Nowraplinks_shortcomings
* http://en.wikipedia.org/wiki/Wikipedia_talk:Line_break_handling#Firefox_bug

Note, that guide is about handling line wrapping in general but those two links are directly to the sections about this Firefox bug. 

The bug is still visible on my Firefox 2.0.0.9 on a WinME. ( Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9 )

.../David
I think this is fixed in Firefox 3 / Gecko 1.9.

(But note that the testcase changed behavior in another way, since we now allow breaks after "-" characters when they're not inside white-space:nowrap.)
Works for me in Linux nightly 2008-02-22-04-trunk; should also work in Firefox 3 betas.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
Target Milestone: --- → mozilla1.9
You need to log in before you can comment on or make changes to this bug.