Last Comment Bug 278891 - white-space:nowrap next to non-whitespace miscalculates text width
: white-space:nowrap next to non-whitespace miscalculates text width
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Layout (show other bugs)
: 1.7 Branch
: Other Linux
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
http://folk.uio.no/hbf/firefox-nowrap...
: 322058 (view as bug list)
Depends on: 101565
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-18 14:22 PST by Hallvard B Furuseth
Modified: 2011-09-09 05:56 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Hallvard B Furuseth 2005-01-18 14:22:32 PST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Firefox only breaks in front of AA here:
  AA<span style="white-space:nowrap">BB CC DD</span>EE
if it would need to break there if the <span ...> was absent.

With normal text, the page becomes too wide for the window.
In a table, the text which should have been wrapped will
continue into the next table column.

Reproducible: Always

Steps to Reproduce:
1. Visit the example URL.
2. Size the window so that paragraph 1 is broken in front of "111".
3. Size the window so that paragraph 1 is broken in front of "xxx(000".

Actual Results:  
1. Line 1, column 1 in the table extends into column 2.
2. "xxx(000" in paragraph 2 does not drop to the start of a new line.
3. paragraph 2 is broken properly.


Expected Results:  
Break the lines in front of 'xxx(<span style="white-space:nowrap">000'.
Comment 1 Boris Zbarsky [:bz] (still a bit busy) 2005-01-30 22:32:42 PST
This is basically bug 101565, as far as I can see... Leaving open for now, but
I'll bet fixing that one fixes this.
Comment 2 Gervase Markham [:gerv] 2005-09-27 02:05:37 PDT
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
Comment 3 Hallvard B Furuseth 2005-10-06 18:28:03 PDT
The bug is still there.  Firefox 1.5 Beta 1.  Leaving a note in Bug 101565.
Comment 4 Uri Bernstein (Google) 2006-01-01 13:24:31 PST
*** Bug 322058 has been marked as a duplicate of this bug. ***
Comment 5 David G 2008-04-10 09:48:04 PDT
I have been responsible for investigating this bug and creating a workaround for it over at the English Wikipedia. This is the same bug as [[Bug 225946]] and probably very closely related to [[Bug 101565]] and many of the other bugs that turn up when I search for "nowrap" here.

Since it might be of help, here is our how-to guide about it at Wikipedia and a link to more info about it at the talk page: 
* http://en.wikipedia.org/wiki/Wikipedia:Line_break_handling#Nowraplinks_shortcomings
* http://en.wikipedia.org/wiki/Wikipedia_talk:Line_break_handling#Firefox_bug

Note, that guide is about handling line wrapping in general but those two links are directly to the sections about this Firefox bug. 

The bug is still visible on my Firefox 2.0.0.9 on a WinME. ( Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9 )

.../David
Comment 6 Daniel.S 2008-12-21 10:42:37 PST
David, or reporter FWIW,

can you still see the problems here? Most of the bugs here have been fixed due to architectural changes.

Please test in the latest Firefox 3 or Shiretoko/Minefield
http://www.getfirefox.com
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/
Comment 7 Hallvard B Furuseth 2011-05-30 05:07:36 PDT
This bug is does not occur in Firefox 3.6.17.
Comment 8 RNicoletto 2011-09-09 05:56:46 PDT
CLOSED per comment 7.

Note You need to log in before you can comment on or make changes to this bug.