If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

An extra </li> displays wrongly as a <li> bullet <li>A <li>B <li>C</li> </li> </ul>

VERIFIED FIXED in M13

Status

()

Core
Layout
P3
normal
VERIFIED FIXED
18 years ago
16 years ago

People

(Reporter: Daniel Weinstein, Assigned: harishd)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Here is a code snippet that shows the bug:

  <ul>
	  <li>A
	  <li>B
	  <li>C</li>
	  </li>
  </ul>
(Reporter)

Comment 1

18 years ago
Created attachment 3811 [details]
the code snippet with two consequtive </li> tags

Updated

18 years ago
Assignee: rickg → harishd
Summary: An extra </li> displays wrongly as a <li> bullet <li>A <li>B <li>C</li> </li> </ul> → An extra </li> displays wrongly as a <li> bullet <li>A <li>B <li>C</li> </li> </ul>

Comment 2

18 years ago
Harish -- I'm giving this to you because you added the code that is responsible.
In HandleEndToken(), there's code in the default section of the switch() that
forces an open tag if only a close tag is found. I think you added it so
that we'd get the extra linefeed. I prefer that this code go away; perhaps we
should just emit a <BR>. Nonetheless, here you go.
(Assignee)

Updated

18 years ago
Target Milestone: M13
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 3

18 years ago
FIXED by not opening an LI for stray /LI.

Comment 4

18 years ago
*** Bug 21845 has been marked as a duplicate of this bug. ***

Comment 5

18 years ago
Fixed in the Jan 20 build.
Status: RESOLVED → VERIFIED
SPAM. HTML Element component deprecated, changing component to Layout. See bug
88132 for details.
Component: HTML Element → Layout
You need to log in before you can comment on or make changes to this bug.