If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Browser crashed while seeing this page

VERIFIED DUPLICATE of bug 225423

Status

Core Graveyard
Java: Live Connect
--
critical
VERIFIED DUPLICATE of bug 225423
14 years ago
7 years ago

People

(Reporter: Jaime Mas, Unassigned)

Tracking

({crash})

Trunk
x86
Windows 2000
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6b) Gecko/20031120
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6b) Gecko/20031120

Mozilla crashes while I'm seeing the page
http://www.wanadoo.es/eventos/accesos/ayuda/adsl.html

Sorry. It only crashes when wanadoo supporting service is avaible.
If you can read the text "En estos momentos el servicio no está disponible.",
please, try it later. Wanadoo costumer service just works at some houers...

Reproducible: Always

Steps to Reproduce:
1.Open the page http://www.wanadoo.es/eventos/accesos/ayuda/adsl.html
2.Wait some seconds until the page is downloaded.
3.Mozilla crashes.

Actual Results:  
Now the service is unavaible, but it crashes every time I visit the page if the
service is avaible.

Expected Results:  
Don't crash.

Comment 1

14 years ago
Confirming 20031120 PC/WinXP
Severity: normal → critical
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: crash

Comment 2

14 years ago
changing component to liveconnect
call stack:
	jsj3250.dll!jsj_GetClassInstanceMembers()  Line 600	C++
 	jsj3250.dll!jsj_JavaInstanceMethodWrapper(JSContext * cx=0x03c28280, JSObject
* obj=0x0148ef80, unsigned int argc=0, long * argv=0x03f47d48, long *
vp=0x0012f1d0)  Line 1800 + 0x11	C++
 	js3250.dll!js_Invoke(JSContext * cx=, unsigned int argc=, unsigned int flags=)
 Line 932 + 0x1c	C
 	js3250.dll!js_Interpret(JSContext * cx=0x03c28280, long * result=0x0012f38c) 
Line 2954	C
 	js3250.dll!js_Invoke(JSContext * cx=, unsigned int argc=, unsigned int flags=)
 Line 949 + 0xb	C
 	js3250.dll!js_InternalInvoke(JSContext * cx=0x00000000, JSObject *
obj=0x012ac630, long fval=20377616, unsigned int flags=0, unsigned int
argc=63079084, long * argv=0x0012f554, long * rval=0x0012f500)  Line 1026 + 0xe	C
 	js3250.dll!JS_CallFunctionValue(JSContext * cx=0x03c28280, JSObject *
obj=0x012ac630, long fval=20377616, unsigned int argc=1, long * argv=0x0012f554,
long * rval=0x0012f500)  Line 3572 + 0x26	C
 	jsdom.dll!nsJSContext::CallEventHandler(void * aTarget=0x012ac630, void *
aHandler=0x0136f010, unsigned int argc=1, void * argv=0x0012f554, int *
aBoolResult=0x0012f550, int aReverseReturnResult=0)  Line 1245 + 0x1b	C++
 	jsdom.dll!nsJSEventListener::HandleEvent(nsIDOMEvent * aEvent=0x01ad0488) 
Line 182	C++
 	gklayout.dll!nsEventListenerManager::HandleEventSubType(nsIDOMEventTarget *
aCurrentTarget=0x02ab2158, unsigned int aSubType=1, nsCxPusher pusher={...},
nsCOMPtr<nsIJSEventListener> jslistener={...}, nsCOMPtr<nsIScriptContext>
scriptCX={...})  Line 1420 + 0x9	C++
 	gklayout.dll!nsEventListenerManager::HandleEvent(nsIPresContext *
aPresContext=0x00000008, nsEvent * aEvent=0x0012f7e4, nsIDOMEvent * *
aDOMEvent=0x0012f770, nsIDOMEventTarget * aCurrentTarget=0x02ab2158, unsigned
int aFlags=7, nsEventStatus * aEventStatus=0x0012f810)  Line 1513 + 0x24	C++
 	jsdom.dll!GlobalWindowImpl::HandleDOMEvent(nsIPresContext *
aPresContext=0x01b124b0, nsEvent * aEvent=0x0012f7e4, nsIDOMEvent * *
aDOMEvent=0x0012f770, unsigned int aFlags=1, nsEventStatus *
aEventStatus=0x0012f810)  Line 846	C++
 	gklayout.dll!DocumentViewerImpl::LoadComplete(unsigned int aStatus=0)  Line
909 + 0x48	C++
 	docshell.dll!nsDocShell::EndPageLoad(nsIWebProgress * aProgress=0x60142bbd,
nsIChannel * aChannel=0x0153cfe4, unsigned int aStatus=64257080)  Line 4326	C++
 	necko.dll!nsHttpChannel::GetURI(nsIURI * * URI=0x00000003)  Line 2615	C++
 	xpcom.dll!nsReadingIterator<unsigned short>::advance(int n=1243292)  Line
179 + 0x12	C++
 	xpcom.dll!nsAString::do_AssignFromElementPtr(const unsigned short *
aPtr=0x02a5b2f0)  Line 302 + 0x3a	C++
 	ntdll.dll!_RtlpFreeToHeapLookaside@8()  + 0x1f	
 	ntdll.dll!_RtlFreeHeap@12()  + 0xfc	
 	ntdll.dll!_RtlpFreeToHeapLookaside@8()  + 0x1f	
 	ntdll.dll!_RtlFreeHeap@12()  + 0x114	
 	msvcr71.dll!free(void * pBlock=)  Line 103 + 0x5	C

Assignee: general → live-connect
Component: Browser-General → Java: Live Connect
QA Contact: general → PhilSchwartau

Comment 3

14 years ago
Dr. Watson shows the same identical stack as in bug 225423 using FB 20031123 on
Win2k. That's why I strongly think of a dupe.

However, it's the first time we get a proper debugger stack for these crashes. :)
Bernard, can you attach this stack in bug 225423 ?

*** This bug has been marked as a duplicate of 225423 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 4

14 years ago
Verified Duplicate -
Status: RESOLVED → VERIFIED

Comment 5

14 years ago
wfm Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6b) Gecko/20031125
Tinderbox BuildID 2003112523, after bug 225423 was fixed

Updated

7 years ago
Component: Java: Live Connect → Java: Live Connect
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.