add bookmark dialog doesn't close after bookmark added

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: Loren Rosen, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6b) Gecko/20031124 Firebird/0.7+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6b) Gecko/20031124 Firebird/0.7+

The add bookmark dialog doesn't close after the OK button is pressed. It gives
no indication whatsoever that it's done anything. The only way to get rid of it
is to press cancel.

I suppose you could argue this is a feature supporting the really important
requirement to add the same bookmark in multiple places in the bookmark menu.

Reproducible: Always

Steps to Reproduce:
1. visit some page
2. select Bookmarks->Add to Bookmarks from the menu bar
3. click OK on the resulting dialog box

Actual Results:  
Nothing happens visually, though the bookmark is added. The dialog box stays up.

Expected Results:  
Taken away the dialog box, or at least give some indication the bookmark has
been added.

Comment 1

15 years ago
*** Bug 227737 has been marked as a duplicate of this bug. ***
Window does automatically close when adding a book mark to a newly created
folder, but not to any existing folder. 

Comment 3

15 years ago
i get this occasionally.  it seems like sometimes the "create in" list is empty,
and then the dialog won't close.  othertimes it works fine.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

15 years ago
With Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031209
Firebird/0.7+ I sometimes can't add bookmark (dialog doesn't close and bookmark
isn't added either). In such case, if I push the button with the tiny triangle
and choose folder in which a new item is added, the dialog close when I push OK
and the new item is added.

Comment 5

15 years ago
confirming the behaviour in comment #4
Firebird 0.8.0+ (20040120) on XP

Comment 6

15 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

Yup, bookmark-add dialog stays open.

Comment 7

15 years ago
I also see the behavior in comment #4 above, except with this Firefox build:

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7b) Gecko/20040312 Firefox/0.8

The "Ok" and "New Folder" buttons do nothing.

Peace...

Comment 8

15 years ago
(In reply to comment #7)
> Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7b) Gecko/20040312
Firefox/0.8
> 
> The "Ok" and "New Folder" buttons do nothing.
> 
> Peace...

It worked in build which I am using.
But, the problem of bug 237136 has occurred in the Add bookmarks dialog...
Furthermore, deletion of the added bookmark is impossible... :-(

Comment 9

15 years ago
oops, sorry spam.
build which I am using is as follows.
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; ja-JP; rv:1.7b) Gecko/20040312
Firefox/0.8.0+

Comment 10

15 years ago
(In reply to comment #7)
> I also see the behavior in comment #4 above, except with this Firefox build:
> 
> Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7b) Gecko/20040312
Firefox/0.8
> 
> The "Ok" and "New Folder" buttons do nothing.
> 
> Peace...

This behavior seems to have been caused by a combination of extensions I had
installed or my having to manually delete a problematic extension since this is
working just fine after uninstalling and re-installing Firefox.

Peace...

Comment 11

15 years ago
(In reply to comment #10)
> This behavior seems to have been caused by a combination of extensions I had
> installed or my having to manually delete a problematic extension since this is
> working just fine after uninstalling and re-installing Firefox.

Isn't it problem about old profile or overwriting (= INVALID),
rather than extension?
I don't see this happen these days, either.

Comment 12

14 years ago
WFM

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a) Gecko/20040427
Firefox/0.8.0+

reopen if you have still see this.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.