Last Comment Bug 226764 - emails corrupted occasionally
: emails corrupted occasionally
Status: RESOLVED DUPLICATE of bug 226761
:
Product: MailNews Core
Classification: Components
Component: Database (show other bugs)
: Trunk
: x86 Linux
: -- critical (vote)
: ---
Assigned To: David :Bienvenu
: esther
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-25 13:10 PST by LeVA
Modified: 2008-07-31 01:22 PDT (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description LeVA 2003-11-25 13:10:02 PST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; hu-HU; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; hu-HU; rv:1.5) Gecko/20031007

After downloading emails, if _it stays_ in the Inbox folder, then after a few
minutes some (but not all) emails gets corrupted. Somehow some mail's headers,
or its body gets overwritten with dots, and after that, mozilla can not display
the mail correctly. This happens only with mozilla mail client, and only if the
mail stays in the Inbox folder. If some filter moves the message to another
folder, then it is "safe". With mc I can see this in the
~/.mozilla/user/xxxxx.slt/Mail/server/Inbox file:
"Received: from taelon.prim.hu (taelon.primserv [10.1.1.4])
        by jam.adver................................." and here are lots of dots.
Or another example:
"Received: from cdm-68-226-201-44.nwib.cox-internet.com (68.226.201.44)
[68.226.201..................." lots of dots too.

Sometimes just the body disappears, and the header stays in the emails. I have
checked if this is a hard drive problem, and copied my mozilla home to another
drive. But the problem still exists. I think this is very serious, cause I can
not read my mails correctly, because this problem happens at random.

Reproducible: Always

Steps to Reproduce:
1. Download mails in to the Inbox folder.
2. Wait some time.
3. Cry...

Actual Results:  
At random, mails gets corrupted, and gets unreadable, because either the body or
the headers gets overwritten by something.

Expected Results:  
Store my emails safely!
Comment 1 David :Bienvenu 2003-11-25 13:18:12 PST
dup

*** This bug has been marked as a duplicate of 226761 ***

Note You need to log in before you can comment on or make changes to this bug.