win32: copy and paste leaves a bogus <!--StartFragment--> comment

VERIFIED DUPLICATE of bug 158103

Status

SeaMonkey
General
VERIFIED DUPLICATE of bug 158103
15 years ago
14 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

win32:  copy and paste leaves a bogus <!--StartFragment--> comment

for reference, see:

http://groups.google.com/groups?q=startfragment+mozilla&hl=en&lr=&ie=UTF-8&oe=UTF-8&safe=off&selm=bdn2r9%24fg31%40ripley.netscape.com&rnum=2

the problem is here:

http://lxr.mozilla.org/mozilla/source/widget/src/windows/nsDataObj.cpp#1065

we need to set the StartFragment byte offset to be after <!--StartFragment-->,
not before it.

1064   ptr = strstr(buf, "StartFragment");
1065   wsprintf(ptr+14, "%08u", strstr(buf, "<!--StartFrag") - buf);
1066   *(ptr+14+8) = '\r';

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 158103 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

14 years ago
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.