Labels set/changed by filters are only stored in .msf file but not in X-Mozilla-Status2

VERIFIED FIXED

Status

VERIFIED FIXED
15 years ago
8 years ago

People

(Reporter: ch.ey, Assigned: Bienvenu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
Now that Bug 224519 is fixed setting labels also affects the X-Mozilla-Status2
field in the mail header. But unfortunately not always.
X-Mozilla-Status gets modified if the label is set by hand or by a filter when
the message arrives.

But it's not modified when running a filter on already existing messages ("Run
Now" button).
(Assignee)

Comment 1

15 years ago
I'll look at the filter case.
Status: NEW → ASSIGNED

Comment 2

15 years ago
My be related to 234935 
(Assignee)

Comment 3

15 years ago
yes, you're right - this is a dup of bug 234935 - it works fine for me here,
except that I don't have non-local line terminators in my mail folders.

*** This bug has been marked as a duplicate of 234935 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

15 years ago
I'm not sure that's a dupe of bug 234935.
This here is about running filter after the fact doesn't update
X-Mozilla-Status2 at all (even if the mbox line endings are the local ones). Bug
234935 is about 
X-Mozilla-Status2 is never updated when having non-local line endings in the
mbox file.

That sounds different to me.
(Assignee)

Comment 5

15 years ago
ah, you're right. I see the problem and it's easy to fix. I'll attach a patch.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 6

15 years ago
Created attachment 145568 [details] [diff] [review]
proposed fix

set the label through the db.
(Assignee)

Updated

15 years ago
Attachment #145568 - Flags: superreview?(mscott)
(Assignee)

Comment 7

15 years ago
correcting component
Component: Mail Database → Filters

Comment 8

15 years ago
Comment on attachment 145568 [details] [diff] [review]
proposed fix

this seems like a good 1.7 candidate
Attachment #145568 - Flags: superreview?(mscott) → superreview+
(Assignee)

Comment 9

15 years ago
Comment on attachment 145568 [details] [diff] [review]
proposed fix

this is a relatively minor bug, but the fix is very safe too.
Attachment #145568 - Flags: approval1.7?

Comment 10

15 years ago
Comment on attachment 145568 [details] [diff] [review]
proposed fix

a=chofmann for 1.7
Attachment #145568 - Flags: approval1.7? → approval1.7+
(Assignee)

Comment 11

15 years ago
fix checked in.
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → FIXED
(Reporter)

Comment 12

15 years ago
Tested and verified. Thanks, David.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core

Updated

8 years ago
Duplicate of this bug: 335094
You need to log in before you can comment on or make changes to this bug.