Label changes on messages are only stored in .msf file and not propagated to mbox file.

VERIFIED FIXED

Status

MailNews Core
Database
--
major
VERIFIED FIXED
15 years ago
10 years ago

People

(Reporter: aceman, Assigned: Bienvenu)

Tracking

({regression})

Trunk
x86
Windows 95
regression
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

3.52 KB, patch
(not reading, please use seth@sspitzer.org instead)
: review+
Scott MacGregor
: superreview+
(not reading, please use seth@sspitzer.org instead)
: approval1.6b+
Details | Diff | Splinter Review
(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

Any change you do on message labels is not kept if the mail index file is
rebuilt. (POP3)

Reproducible: Always

Steps to Reproduce:
1.Label a message
2.Look into the mbox file holding it - there is no change in the
X-MozillaStatus2 header
3.Close Mozilla and delete the appropiate msf file.
4.Restart Mozilla and view the message.
Actual Results:  
Label is lost.

Expected Results:  
Label should be kept even when rebuilding the msf.
(Reporter)

Comment 1

15 years ago
This report is against 1.5. I think this is a regression, because it worked in
1.3 (except that I couldn't set a label to None).

Adding some possible dependencies. There are many more bugs reporting lost labels.

Are bug 107432 and bug 123110 really fixed?
Keywords: regression
OS: Windows 98 → Windows 95

Comment 2

14 years ago
*** Bug 226818 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 3

14 years ago
Created attachment 136370 [details] [diff] [review]
proposed fix

the file pos for the second status line was incorrect - I think the code was
assuming that write updated the file pos, but it didn't...
(Assignee)

Updated

14 years ago
Attachment #136370 - Flags: superreview?(mscott)
(Assignee)

Comment 4

14 years ago
we should definitely fix this for 1.6b/1.6

Updated

14 years ago
Attachment #136370 - Flags: superreview?(mscott) → superreview+

Comment 5

14 years ago
Erm, this patch results in something written out on the X-Mozilla-Status2-line.
But it's not what it should be.

Label  value should   value is
1      0x02000000     0x02000000
2      0x04000000     0x06000000
3      0x06000000     0x06000000
4      0x08000000     0x0E000000
5      0x0A000000     0x0E000000

And if a value is set, it can be set to a higher, but not lower value.
(Assignee)

Comment 6

14 years ago
from what you're saying, the previous label is not getting cleared - that would
be a different bug.

Comment 7

14 years ago
Supposably yes, I wanted to say it just in case.
(Assignee)

Comment 8

14 years ago
Created attachment 136375 [details] [diff] [review]
patch including fix for problem Christian noted

no, it's good you did. The problem was that we weren't clearing the old label.
This fixes that.
Attachment #136370 - Attachment is obsolete: true
(Assignee)

Updated

14 years ago
Attachment #136375 - Flags: superreview?(mscott)
Comment on attachment 136375 [details] [diff] [review]
patch including fix for problem Christian noted

r/a=sspitzer for 1.6b
Attachment #136375 - Flags: review+
Attachment #136375 - Flags: approval1.6b+
(Assignee)

Comment 10

14 years ago
fixed
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
(Assignee)

Comment 11

14 years ago
*** Bug 209164 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 12

14 years ago
*** Bug 165903 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Attachment #136375 - Flags: superreview?(mscott) → superreview+
(Reporter)

Comment 13

14 years ago
Thanks for the fix.
As I can only test final versions, I will reopen or confirm the fix after 1.6 is
out. I will leave it FIXED till then.
(Assignee)

Comment 14

14 years ago
*** Bug 218982 has been marked as a duplicate of this bug. ***

Comment 15

14 years ago
I mistakenly reopened 224519 with the following comment.  Sorry.

After I had Mozilla 1.6a installed for about a week, the label markings
disappeared again from my Inbox.  It was my understanding that this was
corrected in 1.6a, but maybe I am mistaken.  This bug should not be closed.
(Assignee)

Comment 16

14 years ago
*** Bug 209164 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 17

14 years ago
no, this is fixed in 1.6b, not 1.6a

Comment 18

14 years ago
*** Bug 228028 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 19

14 years ago
Fix verified, thanks David.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.