Closed Bug 226971 Opened 16 years ago Closed 16 years ago

Internet Keywords: unrequested google search, and launches unrequested sites.

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 184433

People

(Reporter: mozilla.org, Assigned: bugzilla)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

Firebird appears to do a google "I'm feeling lucky" query when the host does not
respond, or is not found.

To get a simple idea why this is a very bad idea, try 

http://localhost:8080

If you are not running a web server on that port, you end up viewing some random
internet marketing site.

Note that this forwarding occurs even if localhost is your home page, and the
stop button seems to be disabled during the query, so you are going there,
whether you want to or not.

Why this is bad:

1) It turns firebird into adware. Who wants to get a random porn or spam site,
if that is what corresponds to a google query with the name you typed.

2) It takes you to the wrong places. Host names != keywords. if you wanted
http://somewhere.com, and type http://somewhere, you probably won't end up at
somewhere.com.

3) It's very confusing. The URL you typed is gone, and silently replaced by some
unrecognized, and probably unrelated url. 

4) You don't seem to be able to cancel it, since the stop button is greyed.

If this mis-feature is going to be included at all, then at least a check box to
disable is critical (and clearly should default to "don't do it").

Think about the reaction to verisign's site finder service, which did basically
the same thing (though from different motives.)

Reproducible: Always

Steps to Reproduce:
1. make sure you are not running a web server on port 9090
2. type http://localhost:9090 into firebird.
3. note that you end up at http://www.netbreakthroughs.com/
Actual Results:  
you end up at http://www.netbreakthroughs.com/
, rather than the host you expected.

Expected Results:  
If the host is not found, display "host not found". Do not substitute other hosts.
Kinda like bug 171495, but different.

If you want to (sort of) turn it off, you can try this
http://texturizer.net/firebird/tips.html#beh_search

*** This bug has been marked as a duplicate of 95390 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
QA Contact: bugzilla
Resolution: --- → DUPLICATE
REOPEN: Firebird is going to get a couple IK bugs, which will be marked as
depends to Mozilla bugs. Also, IK is going to get a localhost bug as well.
Status: RESOLVED → UNCONFIRMED
QA Contact: bugzilla → benc
Resolution: DUPLICATE → ---
Summary: Firebird does an unrequested google search, and launches unrequested sites. → Internet Keywords: unrequested google search, and launches unrequested sites.
This is a dup of bug 184433.

*** This bug has been marked as a duplicate of 184814 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago16 years ago
Resolution: --- → DUPLICATE
reopening
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

*** This bug has been marked as a duplicate of 184433 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago16 years ago
Resolution: --- → DUPLICATE
V/dupe.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.