If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Firebird crashes on this page, mozilla 1.5 works fine

VERIFIED DUPLICATE of bug 225423

Status

Core Graveyard
Java: Live Connect
--
critical
VERIFIED DUPLICATE of bug 225423
14 years ago
7 years ago

People

(Reporter: Oleg Sidletskiy, Unassigned)

Tracking

({crash, regression})

Trunk
x86
Windows XP
crash, regression

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031125 Firebird/0.7+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031125 Firebird/0.7+

Clicking on the rul causes Mozilla Firebird to crash, but the site work fine in
Mozilla 1.5. Also it appears that the browser crashes after the site is redirected.

Reproducible: Always

Steps to Reproduce:
1.goto http://www.nerdcamp.net/
2.
3.

Actual Results:  
crash
what about with an equivalent Mozilla nightly?  this is probably a trunk bug..

Comment 2

14 years ago
Not Firebird-specific...
Component: General → Browser-General
Keywords: regression
Product: Firebird → Browser
Version: unspecified → Trunk

Comment 3

14 years ago
Created attachment 136464 [details]
testcase - html page

Comment 4

14 years ago
Created attachment 136465 [details]
testcase - Java class file

Comment 5

14 years ago
Created attachment 136466 [details]
Java class source

Comment 6

14 years ago
Created attachment 136467 [details]
Windows generated error log

Comment 7

14 years ago
.
Assignee: blake → live-connect
Component: Browser-General → Java: Live Connect
QA Contact: PhilSchwartau

Comment 8

14 years ago
Save both testcase files to the same directory and open the HTML page.

The HTML file calls the getMsg() method onLoad of the HTML body. The getMsg
should return the string "text from applet", which the HTML should put in the
input box. It works in IE, but crashes in Firebird 20031125 and Seamonkey
2003112008. I'm using JVM 1.4.2_02 and Win XP.
Component: Java: Live Connect → Browser-General

Comment 9

14 years ago
Redoing timeless's change... Sorry.
Component: Browser-General → Java: Live Connect
This does not crash for me with the win32 11/28 nightly.  This is most likely a
duplicate of bug 225423 which has already been fixed.

Updated

14 years ago
Keywords: crash
(Reporter)

Comment 11

14 years ago
does not crash after upgrading to Mozilla/5.0 (Windows; U; Windows NT 5.1;
en-US; rv:1.6b) Gecko/20031128 Firebird/0.7+,

so it's a dupe

*** This bug has been marked as a duplicate of 225423 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 12

14 years ago
Jason: can you confirm this bug is fixed in an up-to-date build? If so,
you can mark this bug "Verified", otherwise you can reopen it; thanks -

Comment 13

14 years ago
Verified.
Status: RESOLVED → VERIFIED

Updated

7 years ago
Component: Java: Live Connect → Java: Live Connect
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.