Closed Bug 227019 Opened 21 years ago Closed 21 years ago

Cookie Manager: Cookie Sites is an empty list when CM started from Eye Icon "Show Cookie Information"

Categories

(SeaMonkey :: UI Design, defect)

x86
All
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: uhaas, Assigned: darin.moz)

References

()

Details

(Keywords: regression)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6b) Gecko/20031124
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6b) Gecko/20031124

If you start cookie manager from the UI's Eye Icon, then select Cookie Manager,
pressing the "Cookie Sites" tab will result in an empty list. However, selecting
Tools -> Cookie Manager -> Manage Stored Cookies and selecting the "Cookie
Sites" tab show correct behavior.

Is something not being initialized correctly?

Reproducible: Always

Steps to Reproduce:
1. Visit a site that stores a cookie, like the URL in this bug
2. Click the Eye Icon, "Show Cookie Information", usually in the bottom right
corner of the UI
3. When the Cookie Notification modal dialog appers, click "View Cookie Manager".
4. Click the "Cookie Sites" tab, the list will be empty.

Actual Results:  
The scrolled list will have no entries.

Expected Results:  
The scrolled list should show all sites that are permenantly blocked.

Since the menu option to start cookie manager shows correct results, it looks
like an (un)initialization error.
Confirmed Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6a) Gecko/20031029

This shouldn't be in cookies, since it's only the GUI that's messing up... 
-> XP Apps: GUI features

Someone want to check on a Mac and change the hardware to All?
Severity: normal → minor
Status: UNCONFIRMED → NEW
Component: Cookies → XP Apps: GUI Features
Ever confirmed: true
OS: Windows 2000 → All
Neil, this might be a fallout from your patch for bug 182359.

Looks like
http://lxr.mozilla.org/mozilla/source/extensions/cookie/resources/content/cookieTasksOverlay.xul
needs to be update to pass in the right type.
No, this is a fallout from bug 220067 - unfortunately the icon dialog tries to
sort the (numeric) status column case insensitively :-(
Keywords: regression
Attached patch Possible patchSplinter Review
By making status a string earlier, we can insensitively sort it (pun intended).
Using release of Mozilla 1.6 on Win 98SE...

Even in the official Mozilla 1.6 release (January 15, 2004), this bug persists.
Will this bug be fixed in time for Mozilla 1.7 (or a nightly subsequent to the
1.6 release)? Is the possible patch posted by Neil proven? If so, how do I
install it?
Attachment #137176 - Flags: superreview?(darin)
Attachment #137176 - Flags: review?(dwitte)
Blocks: 231711
Comment on attachment 137176 [details] [diff] [review]
Possible patch

sr=darin
Attachment #137176 - Flags: superreview?(darin) → superreview+
I got the patch to work. Thanks Neil.

The patch doesn't seem to have been implemented in build 2004.01.25. I have had
to re-use the patch file and repack it in the comm.jar file.
*** Bug 231071 has been marked as a duplicate of this bug. ***
Attachment #137176 - Flags: review?(dwitte) → review+
Fix checked in.
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
*** Bug 237491 has been marked as a duplicate of this bug. ***
*** Bug 237881 has been marked as a duplicate of this bug. ***
*** Bug 239601 has been marked as a duplicate of this bug. ***
Product: Core → Mozilla Application Suite
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: