Cookie manager sort by status broken (stored cookies)

RESOLVED DUPLICATE of bug 227019

Status

()

--
minor
RESOLVED DUPLICATE of bug 227019
15 years ago
15 years ago

People

(Reporter: thesh_bugs, Assigned: darin.moz)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 obsolete attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113

I just upgraded to 1.6 from the 1.5 release to find that I can no longer sort
cookies by status. This was working in Mozilla 1.5.

Reproducible: Always

Steps to Reproduce:
1.Go to Tools - Cookie Manager - Manage Stored Cookies
2.Under Stored cookies, click the button above the scroll bar to the right of
"Cookie Name
3.Check "Status"
4.Click the bar that says "Status"
Actual Results:  
Nothing happens

Expected Results:  
Cookies should have been sorted by their status

Comment 1

15 years ago
Confirming with Gecko/20040116 (WinXP 1.7a)

Javascript console reports an error:

> Error: first[column].toLowerCase is not a function
> Source File: chrome://communicator/content/wallet/nsWalletTreeUtils.js
> Line: 114
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
OS: Windows XP → All
Hardware: PC → All

Comment 2

15 years ago
I've fixed the problem, but I'm having trouble making a patch for submission.
diff/patch is being ugly on my system.
if you continue to have problems, you can post the solution and I can create a
patch based on that for you

Comment 4

15 years ago
Created attachment 140000 [details] [diff] [review]
Patch to allow sorting by status in Cookie Manager

This patch was made by executing "diff -Naur wallet wallet.fix" from the
chrome/content/communicator directory. I don't know how to get patch to apply
it.

Comment 5

15 years ago
Benjamin, let's get your patch into the trunk. At this point, request review and
superreview. If you don't know how, this tells you.

http://mozilla.org/hacking/life-cycle.html
Created attachment 140318 [details] [diff] [review]
cvs diff version of  Benjamin Wester's patch
Attachment #140000 - Attachment is obsolete: true
Comment on attachment 140318 [details] [diff] [review]
cvs diff version of  Benjamin Wester's patch

something isn't right here, some of the lines supposedly added here got checked
in a couple hours ago, attaching a new patch once cvs-mirror catches up
Attachment #140318 - Attachment is obsolete: true
Created attachment 140321 [details] [diff] [review]
cvs diff version of  Benjamin Wester's patch
Comment on attachment 140321 [details] [diff] [review]
cvs diff version of  Benjamin Wester's patch

mvl, darin, this one is pretty straightforward

Benjamin, thanks for the patch!
Attachment #140321 - Flags: superreview?(darin)
Attachment #140321 - Flags: review?(mvl)
Comment on attachment 140321 [details] [diff] [review]
cvs diff version of  Benjamin Wester's patch

heh, see bug 227019, much simpler patch, fixes this issue too
Attachment #140321 - Attachment is obsolete: true
Attachment #140321 - Flags: superreview?(darin)
Attachment #140321 - Flags: review?(mvl)
different symptom in bug 227019, but the cause (and the fix) is the same

*** This bug has been marked as a duplicate of 227019 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.