linux: Drop down menus from the top level menu will appear through several dialogs

RESOLVED FIXED in M16

Status

()

P3
normal
RESOLVED FIXED
19 years ago
19 years ago

People

(Reporter: allenc, Assigned: pavlov)

Tracking

({platform-parity})

Trunk
Other
Linux
platform-parity
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Overview Description:

     The browsers top level menu will retain mouse focus after
  loading the Preferences dialog _IF_ the preferences dialog covers
  the menu.

Steps to Reproduce:

  1) Open the browser.

  2) Open the preferences dialog from the edit menu.

  3) Immediately move the preferences dialog so that the some part of
     the dialog covers the top level menu.  Do this without causing
     focus to move to any other controls.

  4) Move the pointer over the top level menu, which should now be
     covered by the preferences dialog.

Actual Results:

     Drop down menus from the top level menu will appear through the
  preferences dialog.  The behavior is as if we are still navigating
  among the drop down menus, when this navigation is actually
  complete.

Expected Results:

     The top level menu drop down menus should not appear after
  dialogs have been opened.

Build Date & Platform Bug Found:

     M12-1, Debian Linux Build ID: 1999082316

Additional Builds and Platforms Tested On:

     None.

Additional Information:

     Suspecting a window manager or X server bug I reproduced this
  under kwm, icewm and twm, an XFree86 xserver and the VNC xserver.  I
  attempted to reproduce this with other dialogs.  The `Print' and
  `Find' dialogs did not show this behavior.

     My first bug report; be gentle :)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 1

19 years ago
Duplicate of 16018


*** This bug has been marked as a duplicate of 16018 ***

Updated

19 years ago
Status: RESOLVED → REOPENED
Target Milestone: M14

Comment 2

19 years ago
Eh, scratch that, this is different

Updated

19 years ago
Resolution: DUPLICATE → ---

Comment 3

19 years ago
Clearing DUPLICATE resolution due to reopen of this bug.
Hardware: PC → Other
Summary: Drop down menus from the top level menu will appear through the preferences dialog. → [PP] linux: Drop down menus from the top level menu will appear through the preferences dialog.
yeah, i saw this when i bring up the Signon Viewer dialog (from Tasks > My
Wallet > Display Signons...). tested with 2000011110 comm. bits. updated summary
to reflect platform parity as this occurs only on linux, afaik.

Updated

19 years ago
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED

Comment 5

19 years ago
I'm betting this is fixed by beard's rewrite of the view manager, which fixed
transparent menus in general. I'm marking FIXED to get this on the testing
radar until I or someone else can test (I've been fighting to get a linux build
for days).

Comment 6

19 years ago
BULK MOVE: Changing component from XP Menus to XP Toolkit/Widgets: Menus.  XP 
Menus component will be deleted.
Component: XPMenus → XP Toolkit/Widgets: Menus
oops, this seems to have crept in again... tested on linux using the 2000-020209
comm bits. what i did:

1. open up Prefs; as allenc@verinet.com said, do this without causing focus to
move to any other controls (eg, don't click inside the dialog).
2. move Prefs dialog so that its titlebar is over the titlebar of the browser
window (i did this by dragging on the Pref's titlebar), but still exposing, say,
the File menu label.
3. do a mouseover along the Prefs, where the browser menubar would be hidden.

result: the browser menus appear on top of the Prefs.
workaround: click in the Prefs dialog to bring it into focus, and the effect of
mouseovers no longer occur.
expected: browser menus shouldn't appear (should need the workaround).
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Summary: [PP] linux: Drop down menus from the top level menu will appear through the preferences dialog. → [PP] linux: Drop down menus from the top level menu will appear through the preferences dialog

Comment 8

19 years ago
Dan any ideas?

Comment 9

19 years ago
Pink you said you could look at this for me, thanks!
Assignee: saari → pinkerton
Status: REOPENED → NEW
accepting. no promises. cc'ing pav, who has experience with crack-baby X-servers.
Status: NEW → ASSIGNED
oh, pav, you're going to love this one...

This doesn't look like it has anything to do with menus. In fact, before you 
click in the prefs window, you get _all_ rollover feedback from the main window: 
items on the personal toolbar, main toolbar buttons...etc. Furthermore, you don't 
get _any_ rollover feedback in the prefs window until you click in it!

Dan suggested this might have to do with the fact that the prefs window isn't 
really modal due to the superwin landing. Reassigning to pav.
Assignee: pinkerton → pavlov
Status: ASSIGNED → NEW
Component: XP Toolkit/Widgets: Menus → XP Toolkit/Widgets

Updated

19 years ago
Keywords: pp
Summary: [PP] linux: Drop down menus from the top level menu will appear through the preferences dialog → linux: Drop down menus from the top level menu will appear through the preferences dialog
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M14 → M15

Comment 12

19 years ago
Mass-moving most M15 bugs to M16
Target Milestone: M15 → M16

Comment 13

19 years ago
This is working fine with 2000050412 linux. Marking FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED
over to jrgm to verify. most obvious in Preferences dialog, but also affect
Cookies, Stored Passwords dialogs. i no longer see this w/today's bits, tho'.

side note: something in the back of my mind keeps saying, "this was seen on
windows, too." but for some reason, i cannot find another similar bug about that
(dup'd or otherwise). ergh.
QA Contact: sairuh → jrgm
Summary: linux: Drop down menus from the top level menu will appear through the preferences dialog → linux: Drop down menus from the top level menu will appear through several dialogs
You need to log in before you can comment on or make changes to this bug.