Images draw through on to the menus

VERIFIED FIXED in M13

Status

()

Core
XUL
P2
major
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: Stuart Parmenter, Assigned: Stuart Parmenter)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

18 years ago
I can't reproduce this in viewer (unless I load something with boxes).  There
was a bug in the unix drawing code that wasn't checked in the clip region before
it drew an image and was just overwriting the clip region.  I have fixed this
now, but there is still the problem of nsIRenderingContext::DrawImage() being
called when there is an empty clip region.  Now, the reason there is an empty
clip region is because it shouldn't be drawing these images at all.  This is
easy to see with xpmenus because the images from the toolbar under them try to
draw on the menus.
(Assignee)

Updated

18 years ago
Assignee: evaughan → pavlov
Summary: Boxes cause images to be drawn that shouldn't be drawn → [DOGFOOD] Boxes cause images to be drawn that shouldn't be drawn
Whiteboard: porkjockey task
Target Milestone: M11

Updated

18 years ago
Whiteboard: porkjockey task → [PDT+]porkjockey task

Comment 1

18 years ago
Putting on [PDT+] radar.

Updated

18 years ago
Blocks: 16950

Comment 2

18 years ago
mass-moving most m11 bugs to m12
(Assignee)

Updated

18 years ago
Severity: normal → major
Status: NEW → ASSIGNED
Priority: P3 → P2
Summary: [DOGFOOD] Boxes cause images to be drawn that shouldn't be drawn → [DOGFOOD] Images draw through on to the menus
*** Bug 18290 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

18 years ago
Whiteboard: [PDT+]porkjockey task → [PDT+] 12/3/99

Comment 4

18 years ago
Not all images shine through all menus.
In Browser window: Stop button shines though File and Edit menu (oddly enough
not though other menus)

In MailNewswindow: In File and in help menus shine toolbaricons through

Linux build 20/11

Updated

18 years ago
Whiteboard: [PDT+] 12/3/99 → 12/3/99

Comment 5

18 years ago
Per request frum trudelle, removing PDT+ annotation to force reconsideration.
His assertion is that this bug is now fixed enough that it is not a dogfood
stopper.

Updated

18 years ago
Whiteboard: 12/3/99 → [PDT-]12/3/99

Comment 6

18 years ago
Putting on PDT- radar. Not a dogfood blocker.

Comment 7

18 years ago
*** Bug 19155 has been marked as a duplicate of this bug. ***

Comment 8

18 years ago
*** Bug 20278 has been marked as a duplicate of this bug. ***

Comment 9

18 years ago
*** Bug 20308 has been marked as a duplicate of this bug. ***

Comment 10

18 years ago
adding myself to cc: list since this affects mail windows.

Comment 11

18 years ago
*** Bug 19921 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Whiteboard: [PDT-]12/3/99 → [PDT-]
Target Milestone: M12 → M13

Comment 12

18 years ago
moving to m13
*** Bug 18831 has been marked as a duplicate of this bug. ***
adding self to cc list as it'd occur in my area...

Comment 15

18 years ago
*** Bug 17764 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 16

18 years ago
*** Bug 22211 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 17

18 years ago
*** Bug 15986 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 18

18 years ago
*** Bug 19520 has been marked as a duplicate of this bug. ***

Comment 19

18 years ago
*** Bug 22505 has been marked as a duplicate of this bug. ***

Comment 20

18 years ago
cc amusil,prass, scalkins as this affects Aim as well.

Comment 21

18 years ago
*** Bug 22461 has been marked as a duplicate of this bug. ***

Comment 22

18 years ago
*** Bug 22728 has been marked as a duplicate of this bug. ***

Comment 23

18 years ago
*** Bug 17245 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 24

18 years ago
beard just checked in a fix.  he rocks.

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 25

18 years ago
VERFIED Fixed with 2000011808 RH6 build

Comment 26

18 years ago
The problem is still there in a 1/21 pull on solaris/native.  If you mouse
back and forth across the menus, the navigation buttons are rendered over
the menus.

Status: VERIFIED → REOPENED

Comment 27

18 years ago
I still see this on linux with 20000121 builds using aim->file menu.

Comment 28

18 years ago
I'd love some independent verification on this but by my examination this is a REGRESSION. My 2000011808 build does not show 
the error and neither does my 2000012008 build from yesterday. Yet, as duly pointed out the bug does reappear in my 
2000012108 build. So to me at least, it looks like somebody checked in yesterday and broke this again.
Resolution: FIXED → ---

Comment 29

18 years ago
Backing out beard's change 3.18 yesterday to mozilla/view/src/nsViewFactory.cpp
fixes this problem.  Adding beard to the CC list.

Comment 30

18 years ago
beard, was your stuff backed out?
(Assignee)

Comment 31

18 years ago
yes, beard backed his stuff out.  he has a patch that he is going to check in
real soon now that fixes this.

Comment 32

18 years ago
moving to m14
Target Milestone: M13 → M14

Comment 33

18 years ago
Moving from leftover dogfood to beta1 radar
Keywords: beta1
Summary: [DOGFOOD] Images draw through on to the menus → Images draw through on to the menus
Whiteboard: [PDT-]

Comment 34

18 years ago
This should be fixed now, both in the M13 branch, and in M14 tip.
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 35

18 years ago
claudius, can you verify today please?
Target Milestone: M14 → M13

Comment 36

18 years ago
VERIFIED fixed for 2000013114 linux builds.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.