Closed Bug 227346 Opened 18 years ago Closed 17 years ago

large downloads.rdf file brings down the system

Categories

(Toolkit :: Downloads API, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 159107

People

(Reporter: bugzilla, Assigned: bugs)

Details

Attachments

(1 file)

252.64 KB, application/octet-stream
Details
my downloads.rdf is around 1.4 MB and that brings down the entire system (hang)
when I open the download manager

i'm using latest nightly build
Sounds like a dupe candidate of bug 227260, but I'm not sure.
It's not a dupe of that, it's a dupe of the bugs relating to large download lists. 
The same bug happened to me on Windows 98 with Mozilla 1.6 and earlier
You need to clear the list by successive removes of 50 downloads or so
Depends on: 233238
Attached file jprof
jprof of opening the manager with a huge (10k entries) downloads.rdf file. 
There's a bunch of things that can be done about this; I filed bug 233238
regarding one of them.
Possible dupe of Bug 191006, which is a dupe of Bug 161783?
Assignee: firefox → bugs
QA Contact: aebrahim
dupe of 159107 id say.

*** This bug has been marked as a duplicate of 159107 ***
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
No longer depends on: 233238
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.