message filters: mark mail as read, still get new mail notification

RESOLVED DUPLICATE of bug 206050

Status

RESOLVED DUPLICATE of bug 206050
15 years ago
15 years ago

People

(Reporter: paul.stanton, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

my filter moves a message to trash and marks it as read. i still get the new
mail notification and the 'Trash' folder is bold.

Reproducible: Always

Steps to Reproduce:
1. create filter as explained above
2. recieve mail which triggers filter (obviously)

Actual Results:  
i still get the new mail notification and the 'Trash' folder is bold.

Expected Results:  
no new mail notification and no bold on trash folder (obviously)
(Reporter)

Comment 2

15 years ago
almost dupe. will mark as dupe and add extra info to other bug


*** This bug has been marked as a duplicate of 201917 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

15 years ago
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 3

15 years ago
This is primarily a dupe of a different and (to my mind) more important bug, 
altho that is a Mail/News bug rather than T-bird specific.

If you are using the Classic theme in MailNews (and, I gather, in Thunderbird), 
then yes, deleting messages in a filter will cause the Trash folder name to 
become bold, but without incrementing the Unread count.  That is a fairly minor 
issue, solveable by tweaking the CSS as described in bug 201917 comment 14; it 
is unrelated to the notification issue.

*** This bug has been marked as a duplicate of 206050 ***
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.