[quirks]<dl> <dt> indenting does not work.

VERIFIED DUPLICATE of bug 102370

Status

()

Core
Layout
P3
normal
VERIFIED DUPLICATE of bug 102370
18 years ago
16 years ago

People

(Reporter: Josh Wilmes, Assigned: rickg)

Tracking

({qawanted})

Trunk
Other
Other
qawanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME, URL)

(Reporter)

Description

18 years ago
I found a problem with the threaded message display on a web forum.   It uses
a
construct of the form:

<dl>
   <dt>- Level 1
   <dl>
      <dt>- Level 2
   </dl>
   <dt>- Level 1
   <dl>
      <dt>- Level 2
   </dl>
   <dt>- Level 1
   <dt>- Level 1
   <dt>- Level 1
   <dl>
      <dt>- Level 2
   </dl>
</dl>

to represent the messsage threads.   On netscape 4.x, this is rendered as
-
Level 1
     - Level 2
- Level 1
     - Level 2
- Level 1
- Level 1
-
Level 1
     - Level 2

However, for mozilla M12, it is rendered as:
- Level 1
- Level 2
- Level 1
- Level 2
- Level 1
- Level 1
- Level 1
-
Level 2

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 1

18 years ago
Resolving as invalid. The only content allowed in a DL is DTs and DDs (see URL).
The markup you describe, however, is trying to include a DL directly inside
another DL, which is wrong. And Mozilla is allowed to handle incorrect HTML
however it likes.

The way to nest DLs is to put the inside DL inside a DD element -- which makes
sense, since a reply to a message could be seen as the DD to the original
message's DT. So the correct way of producing the nested message display would
be
<dl>
  <dt>- Level 1</dt>
  <dd>
    <dl>
      <dt>- Level 2</dt>
    </dl>
  </dd>
  <dt>- Level 1</dt>
</dl>,
and so on.

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 2

18 years ago
Marking as verified invalid.
(Reporter)

Comment 3

17 years ago
Contrary to the feedback I recieved in reply to this bug, i'm fairly certain
that this behavior WAS corrected (presumably as part of "quirks mode" or
whatever it's called).   However the old problem has returned in the last two
releases of mozilla that i've used.  (Currently I am on Build ID 2001080110, Win32)

I've placed an example document at http://www.hitchhiker.org/bugs/22770.html

Please note that every other browser I have tested has displayed this
(admittedly invalid) HTML as intended.

The particular application which is generating this HTML is outside of my
control, (and is a commercial product), so just fixing the HTML isn't a
realistic option.
Status: VERIFIED → REOPENED
Resolution: INVALID → ---
SPAM. HTML Element component deprecated, changing component to Layout. See bug
88132 for details.
Component: HTML Element → Layout
Could this be Parser?  Could be either layout problem or bad content model...
Keywords: qawanted
Summary: <dl> <dt> indenting does not work. → [quirks]<dl> <dt> indenting does not work.
Duplicate of bug 102370? Don't have a working build here now, so can't test.
Whiteboard: DUPEME
(Reporter)

Comment 7

17 years ago
The bug still exists in 0.9.5 (win32)
Works on a CVS build I just pulled off the trunk. The fix for 102370 must not
have made it into the branch. Duping.

*** This bug has been marked as a duplicate of 102370 ***
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 9

17 years ago
Confirmed- Fixed in 0.9.6.

Comment 10

16 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.