If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

background-color for multiple select renders white

RESOLVED DUPLICATE of bug 224974

Status

()

Core
Layout: View Rendering
RESOLVED DUPLICATE of bug 224974
14 years ago
14 years ago

People

(Reporter: Matthijs Wensveen, Assigned: roc)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

229 bytes, application/xhtml+xml
Details
(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6b) Gecko/20031208
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6b) Gecko/20031208

The background of a multiple select box always renders white. No matter if you
specify
select { background-color: blue; }
or
select[multiple] {..}

this is also true for disabled multiple select boxes. You would expect them to
be gray.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.




Using the modern theme (irrelevant?)

Comment 1

14 years ago
Created attachment 137106 [details]
small xhtml test case

If you save that file as .htm and you open it in Internet Explorer for Windows
it will work as expected.

(there should be a css-forms specification, really!)
Works for me on Linux using a build from this morning. Could this be Windows only?

Comment 3

14 years ago
Confirming with WinXP trunk build, but it's a dupe of bug 224974

Comment 4

14 years ago
*** Bug 224974 has been marked as a duplicate of this bug. ***

Comment 5

14 years ago
*** This bug has been marked as a duplicate of 224974 ***

*** This bug has been marked as a duplicate of 224974 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.