Status

()

RESOLVED DUPLICATE of bug 39683
15 years ago
15 years ago

People

(Reporter: keeda, Unassigned)

Tracking

({testcase})

Trunk
x86
Windows 2000
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

15 years ago
The POI homepage in the url sometimes renders badly. Reload it and all is well.
Looks like some incremental reflow bug in tables. 

I see this in both firebird 0.7 and a fairly current cvs build (which does
contain the fix to bug 215857) I dunno enough about layout bugs to know if this
is a dup of something. 

BTW, POI is using apache forrest (http://xml.apache.org/forrest) to generate
this stuff. So, I suspect that there must be few sites around that are affected
this. I've certainly seen this on the WSRP4J  (http://ws.apache.org/wsrp4j) home
page besides the URL above.
(Reporter)

Comment 1

15 years ago
Created attachment 137246 [details]
Reduced testcase

The table cells should all be the same size but are not.
(Reporter)

Updated

15 years ago
Attachment #137246 - Attachment is patch: false
Attachment #137246 - Attachment mime type: text/plain → text/html
(Reporter)

Comment 2

15 years ago
Created attachment 137248 [details]
Correct testcase

Oops ... attached the wrong file. The two tables should look the same.
Attachment #137246 - Attachment is obsolete: true

Comment 3

15 years ago
I see this on LInux 2003122309.
Do you think this might be a dupe of Bug 217369?  Your testcase looks similar
except Bug 217369 is more verbose.
(Reporter)

Comment 4

15 years ago
It does look like it may be a dup of 217369. I can't tell for sure, since the
testcase in that bug is much more complicated that the reduced testcase in this
one, and I don't know enough about layout and tables to say whether this is valid. 

cc'ing some people who might be interested in a 100% reproducible testcase for
the gamespot.com bug. 
Summary: Table cell too big → {inc}Table cell too big

Comment 5

15 years ago
this looks like a table bug
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

15 years ago
*** Bug 223620 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Keywords: testcase
(Reporter)

Comment 7

15 years ago
Created attachment 139789 [details]
Testcase from Yahoo mail 

It looks like this is also responsible for the weird rendering that I keep
seeing on mail.yahoo.com from time to time. 

I've attached a 100% reproducible testcase reduced from yahoo mail using the
same trick of use a script to force reflow. (The page is modified quite a bit,
but it is far from minimal.)

Note that this page also contains a |width: 12px;| block inside a table
|width="100%"|, and putting a 
<script>var v = document.body.offsetHeight;</script> in a similar place makes
the mis-rendering happen repeatably.

It seems that this has been around for a while. It seems likely that bug
179488, bug 201969 and possibly even bug 218513 (all marked WFM) are the same
problem.
(Reporter)

Comment 8

15 years ago
Comment on attachment 139789 [details]
Testcase from Yahoo mail 

Hmmmm ... this mail.yahoo.com testcase renders fine in my build with dbaron's
latest patch in bug 217369. Obsoleting it. 

No change in the rendering of the original testcase in this bug.
Attachment #139789 - Attachment is obsolete: true
Fixed by the patch on bug 39683.

*** This bug has been marked as a duplicate of 39683 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.