mail start page option can not be disabed

RESOLVED INVALID

Status

RESOLVED INVALID
15 years ago
14 years ago

People

(Reporter: jo3, Assigned: sspitzer)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007

In the "Edit" "Preferences" dialog under "Main & Newsgroups" there is a section
labeled "Mail Start Page" with a checkbox labeled "When Mail launches, show the
Start Page in the message area."  Regardless of the state of this button, the
Start Page appears in the message area when mail starts.  

What is the point of having this option in the Preferences Dialog if the
behavior can not be modified?

Reproducible: Always

Steps to Reproduce:
1. Start the browser
2. Click the Mailbox Icon
3. See the stupid Start Page every single time!

Actual Results:  
The start page came up

Expected Results:  
Mozilla should have gone directly to the inbox screen with the window settings
set during the last session.

Comment 1

15 years ago
I believe that this bug is in fact the other way around: the start page is
*never* displayed, no matter the state of the 'show start page' checkbox.

To verify, go to Edit | Preferences | Mail & Newsgroups, enable the start page,
and click on 'Restore Defaults' under the text field. This should show the URL
'chrome://messenger/locale/start.html' in the text field.

Now open a new browser window, and paste the above URL into the location bar.
You will see a completely different page, which I believe to be the 'start
page', while what you were seeing before is in fact something that's called
'Account Central' or somesuch.

You are right in your observation that the 'Start Page' UI is ineffective - but
what you seem to want as a feature is something different (please correct me if
I'm wrong): you want an option to make MailNews go directly to the Inbox folder
of the default mail account upon opening.

I'll mark this bug as invalid, since it doesn't describe what's actually
happening, and additionally, I'll file a bug on the fact that the preference to
enable the start page is lame UI.

For your feature request, you should file another new bug with severity
'enhancement'.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Comment 2

15 years ago
Oh ...

I just realized that I was confused on what the 'Start Page' actually is as well.

To see what I mean:

o go to Edit | Preferences | Mail & Newsgroups
o enable the start page
o click on 'Restore Defaults' under the text field
o close and reopen the mail window
o go to your Inbox
o select a message
o select Go | Mail Start Page
o see the *real* mail start page *in the message pane*

So that's what's supposed to happen: if you enable the 'show start page'
checkbox, you still go to 'Account Central' upon opening the mail window. But,
if I understand correctly, once you select a Mailbox, instead of an empty
message pane or the last-viewed message, you are supposed to see the 'Start
Page' until you explicitly select a message, at which time the message replaces
the 'Start Page' in the message pane.

However, at least in my build, this still doesn't seem to work properly - I'll
do some more testing and file a bug on it. You still need to file your feature
request for going directly to the default Inbox instead of 'Account Central'

Comment 3

15 years ago
I just found that what you want is already filed; see bug 207567
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.