Location Bar occasionally ignores Enter

NEW
Unassigned

Status

15 years ago
9 years ago

People

(Reporter: jhansonxi, Unassigned)

Tracking

Bug Flags:
blocking1.7 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031208
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031208

Occasionally while typing URLs or partial URLs into the LB, it seems to ignore
the Enter key when I try to load the page.  It seems to be caused by the
History/auto-lookup but I am not sure.  It doesn't seem to be tied to any
particular page.  To get the LB to respond, I have to enter another character at
the end of the URL and then delete it.

Reproducible: Sometimes

Steps to Reproduce:
1.  Manually enter a partial URL into the LB, a fragment of a previously entered
URL.
2.  Hit Enter
3.  Occasionally the Enter key is ignored.

Actual Results:  
Browser would not go to the URL.

Expected Results:  
Loaded the URL when Enter key is pressed.
I think this is a dupe of bug 90337?
Whiteboard: DUPME

Comment 2

15 years ago
*** Bug 228853 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 3

15 years ago
Another manifestation is that if a url is edited, like replacing the id# in the
URL for this bug page with another bug id#, hitting Enter won't load the link. 
But if any other key is hit, the url is sent along with the extra character.  Of
course, if the extra key is anything other than a space the URL will fail
because the resulting bug id# is invalid.
(Reporter)

Comment 4

15 years ago
Another manifestation:  If a partial URL results in a autocomplete history being
displayed, clicking on a history entry causes the URL to be loaded - but not the
URL clicked on.  The partially entered URL is loaded instead.

Comment 5

15 years ago
Confirmed also for Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US;
rv:1.6) Gecko/20040113

As this is not only a Windows/XP bug, I think the original requestor should
update the status. - And maybe update the status to CONFIRMED.
Also I think, that the severity should be at least major as this bug renders
Mozilla completely unusable. Since I have to restart Moz. several times a day to
get around this bug, I'll downgrade to 1.5.1 again.

Comment 6

15 years ago
CONFIRMED: Mozilla 1.6f, 1.7b, and many builds in between on Mac OS X.

This seems to happen after longer sessions, I thought this was a problem w/
going to sleep. I've turned on my go button to see if that will help me
circumvent the enter key problem.
OS: Windows XP → All
QA Contact: benc
Hardware: PC → All
Whiteboard: DUPME

Updated

15 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

15 years ago
?1.7 - asa says this is worth investigating.

"Go" button does work when enter key doesn't. I wasn't able play w/ the prefs
b/c I ran into some weird problem where "okay" and "cancel" didn't work in the
pref UI.
Flags: blocking1.7?

Updated

15 years ago
Flags: blocking1.7? → blocking1.7+

Comment 8

15 years ago
Were there any errors in the Javascript console when this happened?

Comment 9

15 years ago
Still no consistent steps to reproduce. I've looked through Bugzilla and don't
see any obvious dupes.
Flags: blocking1.7+ → blocking1.7-

Comment 10

15 years ago
For me this bug is not "occasionally" but all the time. I don't know if it's
related but I get this in the javascript console whenever i edit the location bar:

Fel: [Exception... "Component returned failure code: 0x80004005
(NS_ERROR_FAILURE) [nsIStringBundle.formatStringFromName]"  nsresult:
"0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame ::
chrome://navigator/content/urlbarBindings.xml :: set_searchValue :: line 401" 
data: no]
Källkodsfil: chrome://navigator/content/urlbarBindings.xml
Rad: 401


However, I get this error whatever I do in the url bar, but the bug where enter
does not work seems to be only when I delete chars from the url. When I type in
new chars and press enter it seems to work.

Comment 11

15 years ago
This actually happens to me on various Macs that I use only, but I can't seem to
narrow down the cause...
I can confirm this on Windows, even on freshly installed Mozilla/5.0 (Windows;
U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041217. My source-build FreeBSD
version does not have this problem.

I am afraid this is somehow related to profile data, not to the core Mozilla
itself. I am using Orbit 3+1 theme, but changing to Modern does not help.

Error: uncaught exception: [Exception... "Component returned failure code:
0x80520012 (NS_ERROR_FILE_NOT_FOUND)
[nsIInternetSearchService.GetInternetSearchURL]"  nsresult: "0x80520012
(NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame ::
chrome://navigator/content/urlbarBindings.xml :: getOverrideValue :: line 432" 
data: no]
(Reporter)

Comment 14

13 years ago
Not that I recall recently.  I do get occasional unexpected behavior when I hit Enter on a typed URL but a autocomplete entry is sent instead because the mouse cursor happened to be resting on the entry's autocomplete pop-up box.  But I don't think it is directly related to this bug.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Comment 15

13 years ago
that sounds like bug 79069

Comment 16

12 years ago
This bug started happening for me most of the time, even in the latest precompiled Mozilla/5.0 (OS/2; U; Warp 3; en-US; rv:1.7.12) Gecko/20050922.  The bug could be triggered by simply opening a DOS session,and could not be fixed without a reboot.  Anothersymptom was that when the bug was triggered, Mozilla
appeared to start using synchronous DNS (the whole page had to load before anything would display).  I fixed it by backleveling the OS/2 drivers timer0.sys
and clock01.sys from third party high resolution timers (needed for Win-OS/2 midi) to the standard IBM drivers.  Then someone suggested I try SeaMonkey. Interestingly, this version: Mozilla/5.0 (OS/2; U; Warp 3; en-US; rv:1.8.0.6) Gecko/20060730 Seamonkey/1.04 has no problem with the high resolution drivers.  So at least the OS/2 manifestation of this bug is some sort of timing issue and switching to Seamonkey covers it up.  Don't know if this is any help but thought I'd pass it along.

Comment 17

12 years ago
I'm not sure if this is the same thing, but having navigated to Wikipedia tonight I tried to edit the address in the location bar only to find that NEITHER pressing enter NOR clicking the "Go" button worked. This turned out to have become the case on any URL on any tab. This is the first time I recall this happening and it was solved by restarting Firefox.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4

Comment 18

11 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12

Recently (in the last week or two) this is happening to me more often.  Today it has been continuous even after reboot (Windows XP Pro, SP2).  

The frustration grows.

Comment 19

11 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12

I experience this problem at least once per day, and I agree with previous posters that it is very frustrating. Only restarting FF solves the problem.

I seem to experience it after viewing a PDF using either Acrobat plugin or the PDF Download 1.0.1.1 add-on. It's as though the other program somehow steals focus and does not properly return it to FF, though that's a total guess!

Thank you for investigating and working to resolve this issue!

Comment 20

11 years ago
I am also experiencing this bug. I have been using FF 2 during the last year and the bug occasionally occurred. Yesterday I installed FF 3 and today I got the same bug again. An autocompleted URL would not load on hitting enter. Even clicking on the green arrow "go to" icon did not help. I couldn't get any new URLs to load, neither in the problematic tab nor in new or existing tabs. The only solution was to restart FF 3; after that, behaviour went back to normal.
I can't give any instructions on how to reproduce this heisenbug. I agree, though, that it's very annoying.

Client: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9) Gecko/2008052906 Firefox/3.0
(Reporter)

Comment 21

11 years ago
@Leo Meyer
I haven't encountered this problem for quite a while.  It may be a Windows-only issue as I switched to Linux several years ago.  It could also be caused by a plug-in, add-on, or custom theme.  Try running Firefox in it's safe mode (which disables all extras) and see if it still occurs.

Comment 22

11 years ago
@Jeff D. Hanson
Hmm... the only add-ons I use that haven't been disabled by FF 3 are del.icio.us and Adblock Plus, and I only use the standard theme. The problem is that the bug occurs so very infrequently. Next time it happens I'll try to play around a little more.

Comment 23

11 years ago
This bug is occurring for me on FF3 running Mac OS X 10.4.11, as well.  I haven't noticed any sort of pattern as to when it occurs.  The only solution is to shut down Firefox and restart it.  I have noticed that, whenever this bug occurs, Firefox seems to take much longer to shut down than normal.  FWIW, I've got Greasemonkey, Delicious Bookmarks, 1Password, and Tab Mix Plus installed.

Comment 24

10 years ago
Jeff D.
did you use delicious or other extensions at any point?

Comment 25

10 years ago
Day before yesterday I experienced the bug again.
It may well be that the bug is being caused by an extension. Maybe we can narrow it down to a specific add-on.
My extensions:
- Delicious bookmarks 2.0.72
- Adblock Plus 0.7.5.5
- DownThemAll! 1.0.3
- Firebug 1.2.0b6
- Flashblock 1.5.6
- NoScript 1.7.7
- oldbar 1.2
- PDF Download 2.0.0.0
- Skype extension 2.2.0.87

However, with FF2 I used only Adblock Plus, Flashblock and the Delicious plugin. This one is currently my best guess to the cause of the bug.

Is there a way to log or debug exceptions in extension code? Maybe an extension event handler throws an error causing FF to abort loading the URL.

Comment 26

10 years ago
This bug is psychic. Not five minutes after posting my previous comment it occurred again.
This time I investigated a bit and found the following:

- Typing and pressing Enter in the URL bar does not work. Neither does clicking on the GO button.
- Selecting an entry from the dropdown list does not load the page.
- Clicking on an RSS feed icon in the URL bar works.
- Pressing enter in the search field to the right of the URL bar works.
- Selecting Firefox bookmarks works.
- Back and Forward buttons work.
- Refresh button works.
- Home button works.
- Toolbar buttons, also those in the Delicious toolbar, work.
- Behaviour is independent whether the CTRL-F search bar is visible or not. Enter still works in its input field.
- Behaviour is independent of whether JavaScript is enabled or not (NoScript).
- F6 and CTRL+L still work.
- When opening a new window (CTRL+N), the new window behaves correctly.
- The behaviour is independent of the URL protocol (http or file etc.)
- When typing, the dropdown box with suggestions closes when pressing Enter.
- Undo and Redo (CTRL-Z and Y) still work in the URL bar.
- Hiding and showing the address bar does not change the behaviour.
- Status bar and sidebar visibility have no effect on the behaviour.
- Code in the JavaScript console is executed when pressing Enter.

Workaround when the bug occurs: Open a new window, drag the current tabs over, and close the offending window.
(Reporter)

Comment 27

10 years ago
@Wayne Mery
IIRC at the time on Windows XP I tended to use Adblock, NeedleSearch, Copy Plain Text, and the MicroFox theme.  On Ubuntu currently I use AdBlock Plus, Forecastbar Enhanced, NeedleSearch, GMarks, and the default Tango theme.  I don't remember it ever occurring on Linux, just Windows XP.  I haven't used Vista enough to notice or encounter it.

Comment 28

10 years ago
In my case, this bug seems to be related to Tab Mix Plus.  Before upgrading to Firefox 3.0.1, I was observing this bug several times a day.  Once I upgraded, Tab Mix Plus wasn't compatible and was therefore disabled.  This bug didn't occur for the entire time TMP was disabled.  Today, I installed the dev build (0.3.7) of TMP, and within 30 minutes of installing it, this bug occurred.  I've disabled it once again, and haven't observed the bug since.  That being said, not everyone who's posted here has Tab Mix Plus installed (at least, they haven't listed it), so this may not be the case for everyone.  Or perhaps the problem is related to the plugin architecture?
Product: Core → SeaMonkey

Comment 29

10 years ago
I also get this, with 3.0.1 on OS X 10.5.4.
For extensions I have:
- Firebug 1.1
- NoScript 1.7.7
- Delicious Bookmarks 2.0.72
- 1Password 2.8.2
- Web Developer 1.1.6

The problem seems to mainly happen in the particular window happens to load links from external apps, like my newsreader.  (i.e. the top most window.)   

Comment 30

10 years ago
I have experienced this quite often when creating a new tab. The main original tab sometimes will still work but all those after won't. As for right now, none of the tabs will load a url. I always end up reopening Firefox and it will work for a while. I've just noticed that it seems to have something to do with the tabs. I am using Firefox 3.0.1.

Comment 31

9 years ago
This bug is definitely reproducible on recent Minefield (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a1pre) Gecko/20090815 Minefield/3.7a1pre (.NET CLR 3.5.30729)) - it started only some weeks ago as far as I remembered.

Reproduction steps that work for me:
- I have "g" as keyword for Google search
- Press Ctrl+T to create a new tab
- enter "g someword" and hit the Enter key
-> The location bar will either not react at all or keep searching for bookmarks that match the text

Sometimes, the keystroke is recognized later, so when I switch to an old tab after doing the Google search, the old tab receives the Enter key. Really annoying :P
You need to log in before you can comment on or make changes to this bug.