Window resize box can overlap with widgets

RESOLVED INVALID

Status

Core Graveyard
Profile: Migration
P3
minor
RESOLVED INVALID
18 years ago
a year ago

People

(Reporter: hsivonen, Assigned: Josh Aas)

Tracking

Trunk
PowerPC
Mac OS X
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3-])

(Reporter)

Description

18 years ago
Overview Description:
The 16 pixels by 16 pixels area at the lower right corner of a resizable window
is covered by the standard size box on Mac OS. There should not be other UI
components occupying that space.

Steps to Reproduce:
1) Open the profile migration window

Actual Results:
The size box overlaps with the "Exit" button.

Expected Results:
Expected the space required by the size box to be reserved for the size box
exclusively.

Build Date & Platform Bug Found:
1999122908, Mac OS 8.5.1

Updated

18 years ago
Assignee: shuang → racham
Component: UE/UI → Profile Migration
QA Contact: elig → gbush

Comment 1

18 years ago
UPM problem; reassigning.

---

Bhuvan, is this a UPM-specific implementation problem?

(If it's not just specific to UPM, please reassign to XP Toolkit/Widgets,
Assigned to: trudelle@netscape.com, QA Assigned to: paulmac@netscape.com.)

Thanks!

Updated

18 years ago
Assignee: racham → trudelle

Comment 2

18 years ago
This behavior is new and I was wondering if any of the new toolkit changes
pushed this. Reassigning to XPToolkit group. If we need to modify anything
in our XUL files, please let us know. Adding gayatri and ben to the cc list.

Updated

18 years ago
Assignee: trudelle → danm
Target Milestone: M15

Comment 3

18 years ago
This is using the wrong kind of window on the Mac. reassigning to danm as p3 for
m15

Updated

18 years ago
Target Milestone: M15 → M16

Comment 4

18 years ago
Mass-moving all M16 non-feature bugs to M17, which we still consider to be 
part of beta2
Target Milestone: M16 → M17

Comment 5

18 years ago
  Perhaps there have been some UI changes since this bug was filed. I'm taking 
the "profile migration window" mentioned in the original writeup to be the little 
progress dialog that shows while a Navigator profile is being migrated. That 
window is resizeable and, I'd say, shouldn't be. I think that's all there is to 
this bug.
  Unfortunately, this window is created using deprecated C++ 
(nsIAppShellService::CreateTopLevelWindow in nsProfile.cpp), so the window isn't 
easily made not resizeable. This wants to be changed over to using JS OpenDialog, 
examples of which are all over the code (nsCommonDialogs::DoDialog, for 
instance). That's the best way to open a window from C++, and it's easily made 
not resizeable from there.
  Reassigning to the person CVS Blame fingers as the original caller of the 
function. Seth, you probably want to bounce it to someone else. This should all 
be straightforward, and it's not a big deal in any case.
Assignee: danm → sspitzer
Target Milestone: M17 → ---
re-assign to racham.  the code that opens the window is his.



Assignee: sspitzer → racham

Comment 7

18 years ago
This one is already fixed on nsProfile.cpp. I used the following to fix the 
chrome style. Then use CHROME_STYLE as your style tag. In case of migration, 
profile manager's toplevel window is loaded with confirm migration text.

#if defined (XP_MAC)
#define CHROME_STYLE nsIWebBrowserChrome::windowBordersOn | 
nsIWebBrowserChrome::windowCloseOn
#else /* the rest */
#define CHROME_STYLE nsIWebBrowserChrome::allChrome
#endif 

In case of this bug, the window that has the resizable handle on it is the 
toplevelwindow opened by nsPrefMigration.cpp 
(http://lxr.mozilla.org/seamonkey/source/profile/pref-migrator/src/nsPrefMigrati
on.cpp#329)

Reassigning to Don Bragg. The above should fix it.
Assignee: racham → dbragg

Comment 8

18 years ago
set target milestone to M17
Target Milestone: --- → M17

Updated

18 years ago
Status: NEW → ASSIGNED
Whiteboard: [nsbeta3-]
Adding nsbeta3 keyword to bugs which already have nsbeta3 status markings so 
the queries don't get all screwed up.
Keywords: nsbeta3
Resetting missed milestones
Target Milestone: M17 → ---

Updated

17 years ago
Depends on: 69976

Comment 11

16 years ago
Reassigning profile migration bugs to the current owner
Assignee: dbragg → racham
Status: ASSIGNED → NEW

Updated

15 years ago
Blocks: 193527
Severity: trivial → minor
OS: Mac System 8.5 → MacOS X
Summary: Window size box can overlap with widgets → Window resize box can overlap with widgets
mass re-assign.
Assignee: racham → sspitzer
(Assignee)

Updated

11 years ago
Assignee: sspitzer → joshmoz
(Assignee)

Comment 13

11 years ago
This bug is no longer valid. Resize boxes on Mac OS X don't conflict with widgets the way they did in classic Mac OS, and we don't have any other issues of this sort at this time.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.