Closed Bug 229092 Opened 16 years ago Closed 10 years ago

serialization to background shorthand is too verbose

Categories

(Core :: CSS Parsing and Computation, defect)

defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: dbaron, Unassigned)

References

(Blocks 1 open bug, )

Details

DESCRIPTION:  Serialization to the background shorthand could use some
improvement.  We should be able to omit -moz-background-* when they're at their
initial values and we can serialize to the shorthand.

STEPS TO REPRODUCE:
 1. load attachment 124962 [details] (originally on bug 125246)
 2. click "Click this to test shorthand handling"

ACTUAL RESULTS:
 * "... green; background: rgb(0, 0, 0) none repeat scroll 0%;
-moz-background-clip: initial; -moz-background-origin: initial;
-moz-background-inline-policy: initial; color:..."

EXPECTED RESULTS:
 * "... green; background: rgb(0, 0, 0); color:..."
Blocks: 377731
Assignee: dbaron → nobody
QA Contact: ian → style-system
Duplicate of this bug: 373878
WFM on mozilla-central.  It's still a little verbose, but doesn't have the -moz-background stuff any more.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WORKSFORME
See Also: → 1134171
You need to log in before you can comment on or make changes to this bug.