crash loading certain text [@ XftDrawGlyphFontSpec ]

VERIFIED DUPLICATE of bug 213734

Status

()

--
critical
VERIFIED DUPLICATE of bug 213734
15 years ago
15 years ago

People

(Reporter: bugzilla.mozilla.org, Unassigned)

Tracking

({crash})

Trunk
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
debian unstable:
  crashes debian package mozilla-firebird 0.7-5:
    Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031215 Firebird/0.7
  crashes mozilla-browser 2:1.5-3:
    Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031107 Debian/1.5-3
  works fine with mozilla.org distribution*:
    Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
    * note, xft does not function somehow

red hat 8.0:
  crashes mozilla.org distribution:
    Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

Produce crash:
1) launch new instance of firebird with the uri:
   $ firebird http://webber.dewinter.com/gnupg_howto/english/GPGMiniHowto.txt
2) scroll down.  browser will crash before reaching end of page.
   Exit code (echo $?) is 11 (segfault).

This crash is reproduceable by just going to that uri, but is not as reliable.

I assume this is related to xft, 
as I could not reproduce this bug with the mozilla.org tarball binary, 
which does not have xft functioning on my computer.
(Reporter)

Comment 1

15 years ago
Created attachment 137837 [details]
one line of ^H chars that crashes mozilla on load

this is an excerpt from the specified URI.
it contains the text:
  VVeerrssiioonn 00..11..00 ((EEnngglliisshh)) AApprriill 3300tthh 11999999,,  
DDuuttcchh QQuueeeenn''ss DDaayy..
with enough ^H characters to read:
  Version 0.1.0 (English) April 30th 1999, Dutch Queen's Day.

Updated

15 years ago
Keywords: crash

Comment 2

15 years ago
can you get a stack and attach it via "create a new attachment" ?

http://www.mozilla.org/unix/debugging-faq.html

if you're using the standard mozilla startup script, just do
% mozilla -g -d gdb
(gdb) run
[wait for mozilla to crash]
(gdb) bt
(attach the output from "bt" here)

do you have Microsoft .fon fonts in your fonts directories ? Does deleting (or
archiving) them prevent from crashing ?
Otherwise, do you have non-readable (with current user) TTF fonts ?
Blocks: 172768
Keywords: stackwanted
(Reporter)

Comment 3

15 years ago
Created attachment 137856 [details]
gdb output from bt command

no .fon files on my system.
all .ttf files are mode 644.

$ cd /usr/lib/mozilla-firebird
$ LD_LIBRARY_PATH=$LD_LIBRARY_PATH:. gdb ./MozillaFirebird-bin
...
(gdb) bt

output in attachment

Comment 4

15 years ago
this should be fixed with either 1.6b or latest 0.8 FB + XFT (which you can try
easily since it's a simple tarball, no deps needed):
http://ftp.mozilla.org/pub/mozilla.org/firebird/nightly/latest-0.8/

Please reopen if still crashing.

Thanks for the detailed report: URL, testcase, stacktrace and investigation,
this helps tremendously.

*** This bug has been marked as a duplicate of 213734 ***
No longer blocks: 172768
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Keywords: stackwanted
Resolution: --- → DUPLICATE
Summary: crash loading certain text → crash loading certain text [@ XftDrawGlyphFontSpec ]

Comment 5

15 years ago
Mozilla 1.7a, Copyright (c) 2003 mozilla.org, build 2003122305

on solaris 8 with xft  build it is not crashing
(Reporter)

Comment 6

15 years ago
works on firebird 0.8 gtk2+xft nightly:
  Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6b) Gecko/20031220 Firebird/0.7+
sorry I didn't check that before.
verifiying resolved.
Status: RESOLVED → VERIFIED
Crash Signature: [@ XftDrawGlyphFontSpec ]
You need to log in before you can comment on or make changes to this bug.