Last Comment Bug 229441 - Background images are not shown in Media tab (Page Info)
: Background images are not shown in Media tab (Page Info)
Status: VERIFIED FIXED
: fixed-aviary1.0, useless-UI
Product: Firefox
Classification: Client Software
Component: Page Info Window (show other bugs)
: unspecified
: x86 Windows XP
-- minor with 3 votes (vote)
: ---
Assigned To: Florian Quèze [:florian] [:flo]
:
: Florian Quèze [:florian] [:flo]
Mentors:
http://www.zeldman.com
: 96994 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-26 03:50 PST by José Jeria
Modified: 2013-07-11 07:40 PDT (History)
7 users (show)
mconnor: blocking0.9-
asa: blocking‑aviary1.0PR-
mconnor: blocking‑aviary1.0-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
This patch should fix this bug (1.93 KB, patch)
2004-07-27 03:23 PDT, Florian Quèze [:florian] [:flo]
no flags Details | Diff | Splinter Review
minor change in the patch (3.29 KB, patch)
2004-07-27 09:54 PDT, Florian Quèze [:florian] [:flo]
db48x: review+
jag-mozilla: superreview+
Details | Diff | Splinter Review
patch (3.24 KB, patch)
2004-07-29 17:03 PDT, Florian Quèze [:florian] [:flo]
asa: approval‑aviary+
Details | Diff | Splinter Review

Description User image José Jeria 2003-12-26 03:50:34 PST
The page info does not show any preview of background images in the Media tab
(page info). Clicking on the background images should show a preview in the
bottom of the dialog.

Steps to reproduce:
1. Go to http://www.zeldman.com
2. Go to the media tab in Page Info.
3. Click on any background image --> no preview is shown.
Comment 1 User image José Jeria 2003-12-26 03:51:16 PST
Branch build 20031223.
Comment 2 User image José Jeria 2004-02-12 06:32:14 PST
Also, clicking on the "Save as..." button does nothing (Bug 178469).
Comment 3 User image José Jeria 2004-03-08 01:06:58 PST
Setting the "?" flag for 0.9 to get some attention. This and the actual
button(save as) are broken functionality in Firefox. 
Comment 4 User image Mike Connor [:mconnor] 2004-04-20 10:53:03 PDT
db48x, should we just be moving these to Browser->Page Info?

anyway, is this something there's a target timeframe for you fixing?
Comment 5 User image Daniel Brooks [:db48x] 2004-04-21 07:54:54 PDT
Yea, it's something I have to look in to. At the moment, however, there's
something horribly wrong with my build (none of the trees anywhere in the
product work, so page info doesn't work at all), so I can't promise more than to
put it on the list.

As for the component, I can find stuff in either place. What is really needed
are two components, Browser:Page Info and Firefox:Page Info, that actually put
bugs in the same place. That'll probably never happen though :P

It would be really helpful if someone could check and see if this is a recent
regression, and if Mozilla has the same problem (probably does).
Comment 6 User image Hussam Al-Tayeb 2004-04-21 10:56:41 PDT
(In reply to comment #5)
No, i remember having this problem too with firefox0.8 final.
Comment 7 User image Mike Connor [:mconnor] 2004-04-24 17:35:29 PDT
You can use View Background Image in the context menu if you really want this,
that's a simple workaround.  Severity -> minor

this isn't a blocker for 0.9, but a fix would be nice at some point before 1.0
Comment 8 User image Stig Nygaard 2004-05-02 06:05:59 PDT
I also see this behavoir in my Mozilla 1.7 branch build 20040501 on Windows 98.
Would sure be very nice to get this fixed for the Mozilla 1.7 release, but thats
just a naive hint/wish from someone who only complains and never actively
develops anything ;-)
Comment 9 User image Stig Nygaard 2004-05-07 00:49:03 PDT
Since I also have this problem in Mozilla 1.7 branch on Windows 98, should't
Product (currently Firefox) and OS (currently Win XP) be changed, or should I
file a seperate bug for Mozilla?
Comment 10 User image Stig Nygaard 2004-05-11 13:22:57 PDT
Related to bug #96994 ?
Comment 11 User image Dennis Benzinger 2004-07-14 10:58:22 PDT
Mozilla 1.7 has the same bug.
Comment 12 User image Florian Quèze [:florian] [:flo] 2004-07-27 03:23:53 PDT
Created attachment 154449 [details] [diff] [review]
This patch should fix this bug

Firefox and Mozilla both have this bug. I think it isn't only with Windows XP.
This patch works for me. Seeking review.
Comment 13 User image Florian Quèze [:florian] [:flo] 2004-07-27 09:54:32 PDT
Created attachment 154463 [details] [diff] [review]
minor change in the patch

the minor change in this patch fix the display of icons and input images which
were having the same problem as background images.
Comment 14 User image Daniel Brooks [:db48x] 2004-07-29 14:55:01 PDT
Comment on attachment 154463 [details] [diff] [review]
minor change in the patch

>+      newImage.width = ("width" in item && item.width) ? item.width : newImage.naturalWidth;
>+      newImage.height = ("height" in item && item.height) ? item.height : newImage.naturalHeight;

can be simplified to this:
+      newImage.width = ("width" in item && item.width) ||
newImage.naturalWidth;
+      newImage.height = ("height" in item && item.height) |
newImage.naturalHeight;

Also, the whole else clause is redundant and should be removed.

r=db48x with those changes
Comment 15 User image Daniel Brooks [:db48x] 2004-07-29 15:16:17 PDT
My bad, the else clause is only redundant if you consider the other changes I
have in my tree.
Comment 16 User image jag (Peter Annema) 2004-07-29 15:40:24 PDT
Comment on attachment 154463 [details] [diff] [review]
minor change in the patch

sr=jag, though I too prefer

newImage.width = "width" in item && item.width || newImage.naturalWidth;
Comment 17 User image Florian Quèze [:florian] [:flo] 2004-07-29 17:03:05 PDT
Created attachment 154710 [details] [diff] [review]
patch

changes done
Comment 18 User image Daniel Brooks [:db48x] 2004-07-29 17:39:48 PDT
Fix checked in, thanks Florian.
Comment 19 User image Hussam Al-Tayeb 2004-07-29 21:25:19 PDT
Will this make it to the aviary branch as well?
Comment 20 User image José Jeria 2004-07-30 00:38:22 PDT
(In reply to comment #7)
> this isn't a blocker for 0.9, but a fix would be nice at some point before 1.0

Now that there is a fix, requesting blocking-aviary1.0PR?

Comment 21 User image Florian Quèze [:florian] [:flo] 2004-08-04 16:16:44 PDT
Can someone edit this bug and move it to "Browser" "page info"?
The fix is checked in the trunk but it isn't in the aviary branch, still waiting
on approval...
Shouldn't this bug stay open until the fix is checked in the aviary branch?
Comment 22 User image Peter van der Woude [:Peter6] 2004-08-04 23:57:57 PDT
It's rejected for Aviary by mconnor so I won't dare to change it
Comment 23 User image Roasted 2004-08-06 02:29:51 PDT
Does this fix inlude displaying the images referred by CSS?
Comment 24 User image Asa Dotzler [:asa] 2004-08-27 14:35:52 PDT
Comment on attachment 154710 [details] [diff] [review]
patch

please don't request approval until you have a fully reviewed patch. thanks.
Comment 25 User image Florian Quèze [:florian] [:flo] 2004-08-27 16:14:02 PDT
(In reply to comment #24)
> (From update of attachment 154710 [details] [diff] [review])
> please don't request approval until you have a fully reviewed patch. thanks.
> 

The patch (attachment 154463 [details] [diff] [review]) is fully reviewed. The only change between
attachment 154463 [details] [diff] [review] and attachment 154710 [details] [diff] [review] is the change requested by
reviewer/superreviewer. attachment 154710 [details] [diff] [review] has been checked in the seamonkey
branch, why not request approval for Aviary since it's been fully reviewed and
checked in the other branch ?
Comment 26 User image Peter van der Woude [:Peter6] 2004-09-22 05:31:16 PDT
there is a patch, it works on trunk, it is reviewed (see comment #25).
All ingredients Asa asked for.
Before this is forgotten forever, requesting ?1.0
Comment 27 User image Mike Connor [:mconnor] 2004-09-22 17:30:28 PDT
its still not a blocker.  If it gets approved and someone checks it in, great,
but its not something we can't ship without.

Please don't use the blocking flags as attention-getters.
Comment 28 User image Asa Dotzler [:asa] 2004-09-24 12:54:09 PDT
Comment on attachment 154710 [details] [diff] [review]
patch

a=asa for aviary checkin.
Comment 29 User image Daniel Brooks [:db48x] 2004-09-24 14:23:23 PDT
Fix checked in on aviary branch
Comment 30 User image Henrik Skupin (:whimboo) [away 02/18 - 02/27] 2004-11-24 14:57:19 PST
*** Bug 96994 has been marked as a duplicate of this bug. ***
Comment 31 User image Tanner M. Young [:tmyoung] 2009-12-04 10:48:59 PST
Verified fixed.

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a1pre) Gecko/20091204 Minefield/3.7a1pre (.NET CLR 3.5.30729) ID:20091204044732

Note You need to log in before you can comment on or make changes to this bug.