Saving of background images from Page Info does not work.

VERIFIED FIXED

Status

SeaMonkey
Page Info
VERIFIED FIXED
16 years ago
12 years ago

People

(Reporter: Jason Bassford, Assigned: db48x)

Tracking

({useless-UI})

Trunk
x86
All
useless-UI
Bug Flags:
blocking1.7 -
blocking-aviary1.0 -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20021105
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20021105

Carry over from bug 176733 which has been marked FIXED.  (This is a specific
instance of a problem from there.)

HTML based background images cannot be saved via Page Info / Media.  (All
other images can.)

See:

http://www.mozillazine.org/talkback/read.php?f=4&i=4543&t=4536
http://www.mozillazine.org/talkback/read.php?f=4&i=4548&t=4536

Reproducible: Always

Steps to Reproduce:
1. Go to the target URL.
2. Right-click on the page and select View Page Info.
3. Click on the Media tab.
4. With the first entry, "tile_gif.gif" highlighted, click on Save As.

Actual Results:  
Nothing happens.

Expected Results:  
A download dialogue should have appeared.

This only happens with HTML based background images.
(Reporter)

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

16 years ago
Same on Mac OS 9.1, Build 2002110408

Comment 2

15 years ago
Same things happens with every webpage that I've visited while using Mozilla
1.4a today. Odd thing is that I was able to download images a few days ago with
no problems and the download manager always came up. Today, whenever I right
click to "save image as" or a link to save a image file to my hard drive, I
either get that my system can't save the image that it's looking for due to an
error with the cached memory or nothing happens.

TonyX

Comment 3

15 years ago
Sorry, I forgot to mention that the same bug/problem occurs while using Mozilla
1.4a for Windows XP and Red Hat Linux 7.2 (kernel 2.4.20).

Comment 4

15 years ago
After debating whether or not this issue will or will not be fixed and finding
out that it not only applies to images, but to nearly any document that is to be
saved; I've decided to downgrade to Mozilla 1.3 as the problem does not seem to
show up there. Sorry.
(Reporter)

Comment 5

15 years ago
Changing reference URL since old one no longer exists.  Note that step 4 in
"Steps to Reproduce" should now read "With the second entry, 'tile_gif.gif'
highlighted, click on Save As."

Comment 6

15 years ago
*** Bug 219492 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Keywords: useless-UI

Comment 7

14 years ago
I can reproduce this with Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.7a)
Gecko/20040307 and Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.6)
Gecko/20040302 Firefox/0.8. Commenting because of the last non-dup comment's age.

Updated

14 years ago
Flags: blocking1.7?

Comment 8

14 years ago
Not going to block for this. A well tested and fully reviewed patch would be
considered for final. 
Flags: blocking1.7? → blocking1.7-
*** Bug 239375 has been marked as a duplicate of this bug. ***

Comment 10

14 years ago
At the moment nothing works there ... see Bug 239472.

Comment 11

14 years ago
*** Bug 247860 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Flags: blocking1.8a2?
Flags: blocking1.7.2?
Flags: blocking-aviary1.0?

Comment 12

14 years ago
Not blocking 1.0 but would be /really/ nice (and not hard, right?) to get a
patch for this, since it's essentially non-working UI.
Flags: blocking1.8a2?
Flags: blocking1.7.2?
Flags: blocking-aviary1.0?
Flags: blocking-aviary1.0-
Firefox specific ?

Now that bug 229441 - Background images are not shown in Media tab (Page Info)

has been fixed it would be nice to see this one fixed too

Comment 15

14 years ago
There is a patch, but daniel brooks is asked to review. Is this correct?
(Assignee)

Comment 16

14 years ago
Comment on attachment 154876 [details] [diff] [review]
patch

r=db48x
Sorry it took so long, I'd forgotten about it.
Attachment #154876 - Flags: review?(db48x) → review+

Comment 17

14 years ago
Comment on attachment 154876 [details] [diff] [review]
patch

Bad UI and a reviewed patch, can this get on the train?
Attachment #154876 - Flags: approval-aviary?

Comment 18

14 years ago
Comment on attachment 154876 [details] [diff] [review]
patch

Removing approval request.  The patch in bug 239472 seems to include this patch
among other fixes.
Attachment #154876 - Flags: approval-aviary?
*** Bug 260815 has been marked as a duplicate of this bug. ***

Comment 20

14 years ago
Isnt this then a duplicate of bug 239472?
(Reporter)

Comment 21

14 years ago
If they are the same, it would be more accurate to say that bug 239472 is the
duplicate.  This one was filed much earlier, also has a patch submitted for
review, and has more votes.

However, if you look at the summary of bug 239472 it's specific Steps to
Reproduce *excludes* the specific case that this bug is targetting.

So, no, there is no direct duplication.
(Reporter)

Comment 22

14 years ago
(However, it appears as if the patch proposed in bug 239472 might fix this bug
also...)
Basicaly, bug 239472 was a regression after the check in of a patch from bug
196971. Bug 239472 was only for Seamonkey. The patch I attached to bug 239472
make page info (in both Seamonkey and Firefox) send referrer when saving media.
I included in this patch the fix for saving of background images. So this bug
isn't a duplicate, but the patch for bug 239472 will fix this bug too.

Comment 24

14 years ago
Can we get a milestone set on this bug, so we have something to look forward to?
Patch 162252 from bug 239472 has been checked in, so this bug is fixed.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
(Reporter)

Updated

14 years ago
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.