Closed Bug 229950 Opened 21 years ago Closed 21 years ago

complete lock with max cpu when using single word in location bar

Categories

(Firefox :: General, defect)

PowerPC
macOS
defect
Not set
critical

Tracking

()

VERIFIED DUPLICATE of bug 229668

People

(Reporter: adam, Assigned: bugzilla)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7a) Gecko/20040102 Firebird/0.7+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7a) Gecko/20040102 Firebird/0.7+

When I type a single word into the location bar, Firebird pauses for about two
second thinking and then completely freezes. Animation stops, no response from
input. I have to force quit Firebird to get rid of it, and sometimes Force Quit
says Firebird is Not Responding.

I tried moving my preferences and any mozilla folders out of Mozilla's path.
This did not alleviate the problem.

Firebird crashes using the following examples:
there
osnews,
foo

Firebird does NOT crash when a space exists such as:
new year

Status bar displays "Resolving foo"

Reproducible: Always

Steps to Reproduce:
1. select/clear the address bar
2. type a single word
3. hit enter/go

Actual Results:  
Firebird completely locks.

Expected Results:  
Try to resolve the word, and if not then an I'm feeling lucky search of the word.
Summary: complete lock with maxxed cpu when using single word in location bar → complete lock with max cpu when using single word in location bar
this has been going on for a few days, i just haven't had the chance to
test/submit until now.
It's a duplicate of bug 229325.
Actually it's a dup of bug 229668, fix checked in today.

*** This bug has been marked as a duplicate of 229668 ***
Status: UNCONFIRMED → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
V/dupe.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.